My Book World II - missing backup folder (Pls Help!)

Hi ,

I have purchased a My Book World II (2TB) NAS and been happily backing up all my family media (photos, videos, etc…) for the last 6 months.  My configuration is non-Raid to get the maxium storage space.  Until last week, we just reaslised that one of our camcorder folder that is also being backup is missing from our computer (a VISTA PC).  So obviously, we turn to the NAS to see if it’s in there and it’s also not.  I wouldn’t have delete this folder from my PC by mistake or what so ever as it contains one of our memorial trips with the kids.

I suspect something funny is going and I cannot prove it one way or another.  However, I can confirm that it was in the NAS a month ago as we were playing the content to our friends on the TV via our DViCo media player.

I would really appreciate if anyone let me know you have encounter similar problem and if so how to fix it (if it’s fix-able).

Thanks in advance!


You should contact WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support


I am on the same boat with you…

I was streaming a video clip from World II with the WD TV live last night, and this morning when I try to open the Media folder, everything are gone… around 600GB pics+HD video clips… yes they are all gone somehow? Like you have said something funny is going on… 

So I have contact WD Technical support, the senior technician asume I have download a lot of private movies… and yea put the blame on the private movies.

why would “I” care to call if those are just private movies… I was on hold for almost 30mins to get to a senior technician, he didn’t even bother to ask me to check the “log” and see if I/someone have deleted it accidentally…

Seriously, what is the different if I lost 100GB or 600GB? The senior technician keep asking me all those #… and suspecting it? I can’t have 600GB movie clips/pictures?

Hi zzz99,

Unfortunately, most Tech Support don’t have a clue what they are talking about.  There are only certain instructions that they follow and blame the user for everything else.  Well in my case, all my videos are from my camcorder so they are not download pirate movies or anything.  I agree, there is no different if you lost 100G or 600G.  What they probably should ask is what file format are configured on the WD NAS - if it’s FAT32 then it will not take any file larger than 4G and so on…

I’ll have to re-consider buying any WD products in future.  But in desperation to recover these priceless video files I will give WD Tech Support a go and see where that take.  I will post the result of this so everyone know.


Hi vquach,

The 1st lvl tech is very nice, she is really trying to help me…(even tho it is very basic…checking) but I am very appreciate.

The NAS is in RAID0, we could put any file bigger than 4GB there. 

I have also suggest my friend in HK to buy it last week and you know what… he got a defective unit… from a brand new retail box…

One more question, may I ask when did you lose the files? Do you check your stuff daily?

I suggest you to copy whatever you have left in your NAS to an external USB HDD before you hand it over to the recovery company. This is what I am doing right now, no more writing on this NAS, just backup.

Hi zzz99,

No i didn’t check it daily.  I’ve been backing up for the last 6 months.  I did check it daily for the first few weeks but since everything is going well then i stopped checking.  So, i know i loose my stuff sometime within the last month or so - since I last access.

I’m in the process of backing up all my stuff before doing anything else.  The support lady suggested that the file system might be corrupted and the folder/fiels might be hidden or files permission been changed.  Well, I’ll try to see if I can recover anything and to see if it’s infact corrupted.

To everyone out there, pls make sure you check your backups regularly because you don’t know what missing.  I still don’t know what else I’m missing apart from this camcorder folder :frowning:


New problem again.

I am giving up WD nas product, GL to u.

A week or two ago a client had a folder named “Backup” disappear.  He first noticed it was gone when a program shortcut on his Desktop that runs his most important program wouldn’t work anymore.

I used Search to try and locate the program the shortcut referred to but Search didn’t find it.

There was a folder named  “Backup” in a folder off the root  with a name like “48585938937478593” which I figured was one of those folders Microsoft Update (or whatever) leaves around, espeically since it had a handful of update-y Opsys-looking files in there dated 2008.  However when I tried to click on the “Backup” folder in there it said Access Denied, even though I was Administrator, user “Owner”.

As it was XP Home I had to reboot into Safe Mode and try to give “Owner” rights to that “Backup” folder, since the Security tab is only available from Safe Mode in XP Home,  but that had an Access Denied problem as well.  I also tried Microsoft command line tools to grant rights but had the same problem.

I downloaded a program off the internet  named Active Undelete 7 Enterprise and it shows Directory listings of both Deleted and non-Deleted files and doesn’t care about rights (since due to its nature it bypasses the Opsys and does its own drive scan to get the directory info), and using that I was able to see that the disappeared folder was the folder in the numbered folder, and then I was able to use the program to copy the “Backup” folder to another drive and get back enough rights to proceed to recover it the rest of the way using the free tool UnLocker to Move folders as well as then moving them with Cut-and-Paste one by one.  (Later on deleting the moved “Backup” folder in that numbered folder was another adventure  (7GB), as was emptying the Recycle Bin after that.)

So keep in mind the folder may have been deleted or it may have been moved by something to somewhere you can’t see it and Search won’t search.