My Book World Edition (white lights) is a nightmare

Hi all,

I have recently aquired a my book world edition network drive (white lights). The drive works absolutely fine with my mac, with my girlfriends windows 7 home premium pc (64 bit), but not with my windows 7 ultimate (64 bit) pc.

i have no idea why.

i have searched extensively for a solution but nothing seems to work. WD link doesn’t work, i’ve enabled every single service in my pc incase i accidentally disabled something crucial.

wd discovery detects the drive but does not allow me to map it. the drive shows up in the network locations but not when i try to map it. i can access it no problems through the ip address (i.e. the configuration and settings etc) but no joy in being able to actually use it.

could someone please help me!! im at my wits end!

Hello mate,

How about reaching WD support for this one.

Try mapping the my book using the IP number, click on start and on the “search programs and files” search box enter “\and the my book ip number”.

@ Awopero  many thanks for the advice - i think this is the last option!!

@ Alucardx23 - this did not work from my pc; however it does from my partners… obviously must be a problem with my pc, i cant help but think it is something so simple…!

cheers for your help

Did you also tried checking the firewall settings?

hi - please forgive my delayed response.

yes - i am using windows firewall and i have switched it off throughout and still not any luck!

many thanks for your continued help.