My Book World Edition(white light) 1 TB - no connection

Hello, I have following problem:  my HD turned off when electricity had suddenly stopped. Afterwards, the front light lights in the bottom, no other activity. Ethernet cable is plugged in, the green light is on, no orange (no yellow) light. Any suggestions? Thanks in advance.

Hi, try pressing the reset button for 4 seconds. 

I did, hundred times, no progress. Any other ideas?

Press and hold the power button for 10 seconds and see if the unit powers down. Then un plug the power lead, leave it for 30 seconds then plug the power back in, chances are it will light one light, and then power off by its self. then press power button until it lights up and leave it alone for an hour or so. Report back.

Hi, I tried to execute the steps. 

The unit did not powered off after the first step. I pressed and held the button 10 seconds, but it did not do anything. The light in bottom part is still on.

pull the power cord out - give it 30s and stick it back in

I did, the light is still on, no changes.  :confounded:

I’ve found this thread:

it describes the same problem.

It seems, there is no solution… :cry:

Hi There…

This may help… I had the exact same problem, no ping, no network presence etc, and tried the various reset options, followed by removing the power cable etc with out any luck  

For me the 10sec power had no effect… The white light just stayed lit…  Pulling the plug, waiting a few secs, and replugging just resulted in the white light, and again no ping etc.

So out of desperation,  I held down both the power AND the reset buttons…probably, for closer to 30secs… Nothing appeared to happen, and I wasn’t that bothered as it had only been a last ditch attempt… however, after a couple of minutes I noticed that it had actually successfully shut itself down… i.e the dreaded white light was off.

Not sure, but I’m wondering if it’s just that the internal processor was running slow, or stuck in a loop or who knows… but the normal power down time did not work.

Holding it a bit longer seemed to help. Again I’m not sure if also holding the reset button at the same time did anything, but I’m not complaining.

After that I just powered it on as normal, and it came back.

Again, I was at the stage of giving up and considering options for migrating the drive to another PC etc., but thankfully it didn’t come to that.

Just thought this might help someone.  :slight_smile: