My Book World Edition (WD20000H1NC) - attempted resurrection

I haven’t switched my MBWE for a few years, but want to use it to do some file shuffling as part of a system upgrade.

When I plug the unit in the disc (WD 2TB Caviar Green) seems to spin up OK, but even after connecting it to several machines (iMac & MBP/Catalina, Lenovo/Windows 10, ThinkPad/Windows 7 Ultimate), I cannot get any of them to recognise it!

I’ve then tried resetting the unit, but even after holding in the reset button for well over a minute, nothing happens (and the same is true if I try to switch the unit off using the on/off button)!

Anyone got any ideas how I might be able to bring the unit back to life?

Many thanks …

PS; on my ThinkPad/Windows 7 Ultimate machine … in my Network and Sharing Centre, when I plug in a direct Ethernet cable directly, I can see an “Unidentified (Public) network” with “No network access” which goes when I unplug the cable - but I can’t do anything with the connection (I’ve even tried \mybookworld but that’s not found!) …

1 Like