My Book World Edition loses connectivity with my PC

I have Windows 7 and the My Book World Edition 6tb drive with a fixed IP address. I mapped the drive in Windows 7. When I copy large amounts of data the drive stops responding. I have the latest firmware and I turned off powermanagement on the PC and on the MY Book World edition. What is causing this? I can load my WD Shared Space with no problem. Is this drive overheating? I am trying to fill this drive with 4TB of data. The first time it copied for 9 hours and then lost connectivity. Everytime after that it only copied for 15-20 minutes and then loses connectivity.  The only way to restore connectivity is to unplug the drive and then plug it in again.

When the drive loses connectivity if I used WD Link then it does not show up in the list.

there are many posts on this. follow mine to your answer but youll need some linux skills.

Filezilla works great on my Worldbook but not on my WD Shared Space. I opened a new thread on the WD Shared space forum. The connection gets closed.

I experience the same issue over and over.

It says “solved” … what is the solution ?

I’m over this piece of **bleep**. Over $500 for something that has only succeeded in wasting my time and create stress!

I’ve got it dialled in with the latest firmware, static ip and its pathetic how bad this product is.

When its connected to the network its so slow its not funny and when I connect directly with the PC via the network cable connectivity is difficult to obtain and when it does it drops out continuously.

I’m taking this back to the retailer TODAY!

Anyone have any suggestions as to a real Network backup solution?

Lol, this is ridiculous! I have a 1500 gb movie collection on my mbw, and I can’t do **bleep** with it. It’s faster to download a movie again rather than copying it from the mbw to my pc…

I’m tired of this bull**bleep**. This is the greatest piece of **bleep** I’ve ever bought. WD should give all users of this thing a free, modern, replacement. You can’t call this a NAS, even when connected directly to the pc I can’t play a movie from this thing.

I can’t support a company that creates **bleep** like this.

Farewell WD

Well, I have to say this. I guess my forum post was a bit over the top, and I might want to recall I don’t support WD anymore.

Today I was called by someone from WD customer service, and they apologized for the bad performance of my NAS.

They offered me the choice to get extra disk space or [edited]

I must say I am impressed. I never expected you guys to even read this message, so great job :wink:

I won’t buy a new nas from you, but your hdd’s are still welcome :slight_smile:

Thank you WD for your great customer service!

Best regards,


I seem to be having the same problem with my drive locking up when I’m in Windows Explorer. I’ve spent the last hour trying to get a simple photo from a directory and have given up.

Honestly, this drive has been one of the worst things I have ever purchased and have had nothing but problems with it from day one. Most I manage to get around but I am at my wits end trying to access my own data.

Does anybody have a solution?  jdz2k’s post looks pomising but can’t find a solution in their post history and I’ve never used Linux. 

Please help :frowning:

wow Marcoevich, i wish i could have gotten a hdd or something for the year of locking up i had w/ this nas. only by the genius of the board members did we figure it out. wd wouldve required me to send it in and swap it…only to have the same exact issue. 

I’m just wondering where the solution for this problem is as the posts in this thread seem so cryptic.

I’ve been looking in various threads and can see plenty of discussion but haven’t encountered a solution. jdz2k, do you have a link to the thread where this is answered as I am coming close to throwing my hard drive out the window and am a bit perplexed that if this is such a common fault why I can’t find a solution (unless I’m looking in the wrong places).


Re: Large File Problem eg. Backup-Jobs

03-07-2011 01:05 PM - last edited on 03-08-2011 07:19 AM

ok thanks. ive implemented this and disabled mionet as it definetely causes my book to freeze up also.

030811 update: the 64GB upload was a success!! i think we may be on to something here. here is a snapshot of what i did.

  1. followed LarsMaschke post to remove “nice -n -20” so that it just says " /usr/sbin/smbd -D" in /etc/init.d/S90smbd.


  1. followed Vlado post to disable everything mionet (I didnt do mv /etc/init.d/S97twonkyserver /root which deals w/ twonky) and i also edited /usr/mionet/ to make Mionet obey startup flag.


  1. reboot through putty and/or web interface.

i had undone everything else i’d tried on the forums here so truly mionet is the only thing disabled.

Thank you, I will give that a try later on. I saw that topic but didn’t look as for me it’s not even copying large jobs, it’s just browsing and it locks up. Mionet is a nice idea but one of the worst programs I have ever encountered and it has been the cause of most problems, so any way that I can use my WD drive without having to rely on Mionet would be wonderful. Thanks.


On my particular case, which seems to be the same as the 100% of MBWE II White Light, that the NAS hangs and have to take out the power cord to get it back to life.

What I found is that my NAS inside gets up to 45ºC/113ºF, so I’m suspecting the main cause of it is the temperature.

The worst thing is that it doesn’t come with a cooling solution, so I’ll have to try to put on top a cooler to take out the heat from it and see what happens.

Anything I could try by config, to low down temps?