My Book World Edition II (white light) will not reconnect

Very frustrated, so I hope I can take advantage of the expertise on this site. I set up my WD20000h2nc drive a couple years ago and it ran great. We recently moved and I had some difficulty getting it connected and working again, but long story short, I was successful. I have the WD Anywhere program running to automatically back-up two computers on our home network and all worked great…

Unfortunately this week i noticed the drive was no longer accessible. When I’m in Windows Explorer I still see the names of the folders (X and Y) but there is a red X next to each. I also see WD My Book World Edition II (Public) listed under the Computer section. There is no red X, but when I try to access My Book World Edition II it trys and then comes back with an error saying “Windows Cannot Access \\Public”

I have run WD Link and it immediately sees MyBookWorld with an IP of (so I know it’s accessible). However when I click to “Map Drive” it returns a “Failed to map drive” message no matter what Drive Letter I choose. 

I’m simply trying to get my drive reconnected so it can continue backing up files and I can access them. Both PCs are running Windows 7. Please let me know if I left anything out in order to get an answer. Thank you in advance. 


Have you tried assigning an IP to the drive? Maybe the one that it had before. For some reason your router is assigning a different IP to the drive.

Thank you for the reply. How would I assign an IP to the drive? The fact that it’s seeing the drive with WD Link shows me it’s connected, but unfortunately is not accessible. 


Can you log into the control interface for the My Book World at ? To set the IP address you need to go the the Network tab. I have attached a screen shot of my unit. It is set up with a Static IP, but you can also select DHCP for automatic IP assignment. On a home network, you are very likely in the 192.168.1.x address space. The Default Gateway in the screen shot is my router at You do need to come up with more information if you are going to set a Static IP. It should be possible to get this information from your router interface if you want to go this route.

Good Luck! Hope this helps.

1 Like

I have tried to log into the control panel. Previously when I tried I could not log in (using admin/admin). Now I continue to get this error message. 


Ouch. On a quick search for that error the best I’ve come up with is to try restarting the MBW. You might go one step further and do a reset. Instructions here-

Very Long Link

This will reset all the configuration to default and reboot the system, but leave your data intact. User name: admin, password: admin, auto IP (DHCP). I’m not sure what else gets reset. You will want to go through all the settings if this gets you back in. After the server boots back up, look at WD Link and see what address is reported. Then see if you can get into the control panel.

What address range are your computers running in? It would usually be 192.168.x.x for a home network. The 10.x.x.x range is also a private address space, but it is more common in larger business environments. There is some information about that here-

You probably want to check what your router is doing, too. Its control interface ought to let you see the devices on the network.

1 Like

Thank you so much for your patience and insight! I did reset the MBW and was finally able to log in to the panel. I also logged into my router and it does use the 10.x.x. range and when logged in it sees the MBW:

The MBW information looks accurate as well:

The WD Link still can find the MBW, but when I click “Browse” I get the following:

So in summary, the MBW is on the network, WD Link sees it, but I cannot get the connection to work. Any more thoughts/questions?

Hmm. It’s strange that the dashboard is availble, but not the content of the drive. I’m just fishing around at this point. You might try the following-

In a Windows Explorer window type into the address bar (no quotes):  “\mybookworld\public”  This is just another way to try to get it to connect. It is unfortunate that the MBW does not have a Diagnostic Test option like the My Book Live. I would have to do some digging to figure out if there’s a way to make the MBW system run a disk check. It would require using SSH (Secure Sockets) via something like the Putty app, but I am not conversant enough in Linux (MBW operating system) to advise. As far as that goes, the Storage and Status tabs in the dashboard do report disk condition in a very general way.

I will post back if I think of something else to try. I hope maybe one of the more savvy users here will offer suggestions.

Hang in there!

1 Like

Thank you so much for your help on this, I really appreciate you taking the time to think through this. I did try the \mybookworld\public, but unforunately it did not connect.

Hopefully someone else can come up with something, you’ve been great!

Does anyone else have any insight? I can access the MBW admin page, my router shows the MBW is connected, but I cannot access it from Windows Explorer.

I’m sorry I have not come up with any other ideas. Contact WD Support. Maybe they can help you out.