My Book World Edition II(white light) power and reset buttons not responding!

I got very old My Book World Edition II(white light) device from my friend,
when I connect the power DC it the below LED is on and the upper one is truing on off for every 5 seconds.
when I connect it to my router, the router does not show me it as connected also from back of it on cable there is only one LED on.

I have tried to reset it for 4, 20 and more seconds but nothing is happing ! its not getting reboot or show any indication, even the power button is not responding !
both buttons not responding,

I have tried all the way everything to reset the device,

power on and press , power off press and connecting power, with HDDs and without HDDs

tired to connect directly to laptop and check the arp -a, no luck,

did anyone face same issue before?

It seems that the drive may have gone bad.

You should contact WD Support for such concern. You can contact WD Support from the link given below.


this was the respoince from support :

Thank you for contacting Western Digital Customer Service and Support. My name is Andrew.

This case is regarding the recent KBA Feedback ticket you created.

I understand that you are having issues with accessing the My Book World device.

Please note that this is a legacy unit that has limited support available. It could be possible that the reset button has failed, or the firmware chip on the device is corrupted and does not allow the reset to proceed.

In most cases, these devices turn out to be faulty, and no troubleshooting step will make it accessible.