My Book World Edition II not responding to web browser, WD Discovery, SSH not enabled


#1

Good day,
I have a My Book World Edition II (white lights) that has stopped responding to the web browser access.
The unit has 2 x 1TB drives and, apart from the inability to access, its lights seem to indicate that it is operating normally.
When I disconnect the network cable and re-connect it, I get the notification e-mails. It responds to pings, it appears in the arp table of my computer. I have disabled all the antivirus softwares (AVG, Windows) and am still unable to access it. When I reboot the MBW however, I AM able to access its web server for only a few seconds–I get a screen saying that it is starting up, with a progress bar that stops at 5%. No further access is available after that.
I have tried resetting the unit (20 second press on reset button), it seem to be successful because the MBW does all the alternate light sequences, then shuts down and restarts but there is no change with my issue. One remark here however, after this reset, the unit still comes back on the same IP address as before -192.168.2.18- so that means it is still obtaining the IP address from my DHCP router. I have tried connecting with my laptop with simply a cross-over cable (by setting my PC to 192.168.2.19) and again, I can ping the MBW, but not access it over http.
Also, the WD discovery tool doesn’t see the unit either.

Unfortunately, I never enabled SSH when web access was available.
I have a backup from January, but I’d like to try recuperating as much as possible.
Do I have any options?
Thanks!


#2

Hello,

I recommend you contact WD support for assistance with your drive.


#3

With no news from WD support, I continued my research into ways of recuperating my data. Most means involve using a Linux computer, and I happened to have one with Linux Mint lying around. I am now copying my data to another NAS in my network (it will take 15 hours because the Linux PC only has a 100Mb NIC). With a USB-SATA adapter, the transfer initially said that it would take 179,000 hours. So I mounted the 1TB drive inside the PC in place of the CD, and the transfer is happening faster.

There are several explanations on line about mounting WD drives into a Linux system, and I ran into errors when trying those instructions on the RAID partition.
The trick turned out to be the file type when mounting that RAID partition.

After creating the directory to where the WD drive will be mounted with:
sudo mkdir /mnt/wdbackupdata
I used:
sudo mount -t xfs -o rw /dev/sdd4 /mnt/wdbackupdata
Once the disk was mounted, I used the file browser to copy the files to the new NAS.
Note that the “sdd4” may change, but my Linux Mint had a disk utility that identified the WD disk correctly. I’ve seen fdisk -1 suggested, but that only gave me an error.


#4

Hi Jofrah.
I can see the last activity is a while ago, but it happens that my “My Book W E White Light” is having similar problems starting when i would use it more intensively which means to play cd-music from. I can use it for several hours , then suddenly it stops responding. I can then switch off and then on again and it will work for some time again. I have not tried much yet, and just starts considering getting another nas not to waste too musch energy on this. I would like to hear from your experience on your case.
Thanks in advance.
regards I_vanhansen


#5

Hello i_vanheusen,

If you can still access the data normally for a certain period of time, I suggest you download everything as quickly as possible to another device before your My Book becomes completely unreachable. This may take several “download sessions” if the drive is only accessible for a certain period of time, but this is certainly better than mounting the drive on a Linux machine and finding your way to the data files in the labyrinth directory structure of Linux. Manual transfer is suggested because a “Backup” may not have time to complete before the system crashes, and would re-start from scratch every time (unless you have an “intelligent” backup).

Good luck!