My Book World Edition II 2TB External Network Dual-Drive Hard Drive Firmware Upgrade Failed

I was updating the firmware on my drive, which I run in a mirrored configuration. The browser reported the update was successful. However the system never came back after the reboot. The status light on the front is stuck at 1/4th. I have tried multiple times to reset the system (making sure to hold the reset button more than the required 20 seconds) - did not help.

WDC support has been less than helpful. Told me I should do a system reset - of course, I can’t because the system won’t boot.

I asked if there were alternative - only option they offered was to get professionals to pull the data from the drive.

I am getting a replacement unit from them. The problem I see is that the drives I return may have all of my data on them. The RMA process does not allow you to enter any comments, so I can’t tell them that I would like the drives thoroughly erased before they are used again.

That’s something you don’t have to ask them to do.