My Book World Edition-dead after failed firmware

I attempted to update the firmware in my older(2008) My Book World Edition and left it to download and install the 30 minutes the screen suggested.  Internet went out unexpectedly during upgrade and the unit comes on  now, but it is not able to be found on a network.  Tried to reset it multiple times.  Blue power comes on by power button, but no way to access it or get to the folders.  It worked fine before firmware upgrade.  Any suggestions on how to get it repired or aqt least get the data off the hard drive that is in it if it is a toaster now?  is there software that can access the hard drive if i put it in a USB cradle?

The drive will not work on USB. If you have a MBW white light you can try connecting to the PC direct trough the ethernet port.  Open a web browser and type \mybookworld and see if able to find it. 

1 Like

The Blue Ring is illuminated and it powers up, but i can not connect thru the internet connection.  It does not show up on my router as requesting an IP address thru DHCP either.  Is it possible to palce the hard drive that is in a NAS mode I assume, in a working My Book and copy the info off or will the hard drive not work in another WD My Book?  Will it work in a newer My Book model or does it need to be the same 500Gb model?

The drive might or might not work with a different enclosure. If you’re certain that nothing else can be done ( like calling WD) then you can try that.

1 Like

I did find software that reads the files off of the hard drive in the ext3 format and will convert them onto a standard windows hard drive in NTFS.  Software I found at

It did cost some $, but is easy to use.  :smiley: