My Book World Edition (Blue Rings) 2TB Help!

Okay, my device won’t power up anymore. It was working fine til yesterday and I needed to reset the admin password and had to unplug it. Ever since then it hasn’t been able to turn on except once by chance (I then unplugged it again to put it back in the other room it was placed in. Now it won’t turn on at all. I hear the drives spinning and everything. And that time it worked by chance, all the data was in it intact but just slow transfers. Anyone know what I can do to recover the data from the hard drives.

It has two 1TB hard drives in it and is setup as Linear. I tried to put the hard drives in a different drive enlosure to see if it can read it, but it can’t be read.

Please if anyone can give me an idea of recovering data or just trying to make the original device turn back on. Also the LED lights up for a milisecond when I first plug in the power. Thanks! 


Normally the internal drives on those units are formatted on .ext3 file system that is compatible with linux format… You might be able to get the information back connecting the drive to a linux computer…