My Book World Edition and OS X Lion (10.7) and Time Machine

My Book World Edition not compatible with 10.7 Lion.  It appears the issue here is a different version of Netatalk in Lion and one of the libraries it uses for authentication.  I’m wondering when he and IF an updated version of Netatalk will be included in a firmware upgrade, or if these devices are not going to be supported by WD for Lion and the community will have to compile a solution?



I have the same problem. It looks like this issue has been known to WD for several months, but they were waiting for Lion to be released. That’s happened.

WD, will this problem be addressed via a firmware update and when will that be released?

In the meantime, my backup/restore functionality on my Mac is disabled, and I need to get this addressed before I upgrade to Lion (which I’ve already purchased).

Same Problem to me, the following Message appears whren i try to make a Backup: (German) Die Version des Servers, zu dem eine Verbindung hergestellt werden soll, wird nicht unterstützt. Wenden Sie sich zur Behebung des Problems an Ihren Systemadministrator.

So WD go forward to solve this Problem fast, please.

This is far from an ideal solution, but it is at least a solution. I recognize that it won’t be acceptable to some, even as a temporary solution.  It will work for me for the short term, but I really hope WD can fix this fast.

  1. login to the web interface on your MBWE
  2. click on Advanced mode
  3. click on Users
  4. click on Folder Share Permissions
  5. for the first shared folder that you need to make available, click on the edit icon on the right
  6. check the Enable box for Public Access
  7. click on Submit
  8. repeat steps 5-7 for every share you need
  9. login to your MBWE using SSH (you may need to enable this in the web interface if you haven’t already)
  10. cd /shares  (it will probably be there already)
  11. cd into each share directory
  12. chmod 777 *   (change the permissions on every directory in the share to be world readable/writable/executable)

Now you should be able to connect to your MBWE as Guest and access your shares.

As I said, not an ideal solution, but it’s working for me.  I installed Lion before knowing about this problem, and I have files on my MBWE that I simply can’t lose access too, even for a short period.


1 Like

The only “Folder” i can not access ist the WD Backup, all others shares work.

Mine not wokrking either - come on WD! When can we get an update?

I understand that you guys are frustrated but, you have to give WD  a chance, imagine that im running linux and i have no support at all…lets just give this guys a few days to see what they come up with

This is an issue for me too.  Just upgraded to Lion and now my MyBook World won’t function as a Time Machine disk.  The error I got is:

The version of the server you are trying to connect to is not supported. Please contact your system administrator to resolve the problem.

Same problem here, naturally.  I’d be more likely to remain patient if a WD employee posted a commitment to release an update in these forums.  I understand that release will need to be prioritized against other work but saying nothing will only amplify the community’s anxiety.

Hi Guys,

I had the same issue and hopefully it get’s fixed through a firmware upgrade. In the meantime there is a very good workaround described here that worked perfectly for me:

AFP connection workaround

Same problem here, when I tried to fix it with the ezeedijk’s solution (AFP connection workaround), i got this new error: 

update the firmware, my book world with lion all ok.

Can you please tell which firmware you are running?

Mine is running on 01.02.06 with MioNet and could not make it work with lion. Tried to update the firmware but always comes back that my device is up to date. what firmware version are you running?

Thats the error I get - the explination form WD is clear enough to me.  I can wait for the upgrade… Lets not rush them and make a pigs ear out of it.

At this time, there is no way to use Mac OS X Lion and Time Machine with the My Book World Edition. We have to wait for a firmware update. All solutions are relateted to use Lion and the NAS as file server using AFP. If you still have problems with this scenario, use the workaround from Alexander Wilde:  Lion + NAS + AFP. But once again, it is not a solution for Time Machine!!!

Here another customer waiting for the firmware. Just to put some pressure on it, although it might not be needed :wink:

Regards everyone

Ok the workaround works for files. So we have to wait for a firmware that supports time machine :confused:

WD… We deserve an update! I can access my files but no backups…

To me it seems very strange that the problem came overnight and the beta tests didn’t find it out :frowning:

1 Like