My book world edition 2 (white light) died on me

Hi Everyone,

I have been a happy owner of a 2tb My Book world edition 2 for approx 2 years.  Apart from it being slow I couldn’t fault it.  It just quietly sat there on the shelf making sure that backups were done.  I also used the drive to store ALL family photos.  The setup was raid 1.

Approx 2 weeks ago I noticed that the drive vanished from the network.  I went to have a look at it and found the bottom quarter of the white light bar flashing.  I tried to reset with no success.  I changed power supply and nothing.  I’ve come to terms with the fact that the unit has packed it in.

What I am wondering is how to get to my photos on the drives and recover them?  I know that My Book runs on linux and I guess the drives are formatted in a different and foreign to me file system.  Any help on how to recover the photos would be very appreciated.

Thanks guys.


Just in case you need to press the reset button for 4 seconds. The internal format for the HDD is ext3, you should be able to take out one of the internal hard drives and connect it directly to the computer motherboard, check the link below for some suggestions on how to read the ext3 on window.

Thanks for the suggestion.  I will give it a go.  I tried the reset button and I have written to WD.  They suggest that my drive needs to be replaced but I need to recover the data myself. 

Just one more question.  You say I should connect the drive directly to the motherboard I guess via a sata and power cable.  Will this also work with a sata to usb converter??  I only have a laptop handy at the moment.

BTW I see more and ore posts regarding frozen WD NAS that won’t boot :frowning: