My Book World Changing Permissions


#1

I have a networked My Book that is on a network with both Mac and PC.  All was fine until a couple of days ago the permissions were changed to read only.  The drive still shows up as read/write but when trying to write to the drive it gives the message that I don’t have permission.  Also when I try to change the permissions from either computer it says that I again don’t have permission to make the change.

Anyone have this problem or know of a fix?


#2

Have you tried going into Applications/Utilities and opening Disk Utility and verifying and/or repairing permissions on your Mac’s internal HDD ?  Do the Internal HDD first as it might not be necessary (or possible even) to do this on the external drive. 


#3

I had the same problem with permissions, and when I went to use disk utility, repair was greyed out. 

I’m using a WD as a time machine back up for my intel mac. I am not running PC on it, just OS 10.5.8

Here’s what I did and it worked for me. I’m not a pro, but this seems to be working.

Yesterday I ran a repair permissions on my internal HD. It stopped at the the Western Dig HD. Repair for that drive was “greyed out” not an option. I have a second hard drive so today  I backed up all my important stuff on it. Then in disk utility I “Erased” the WD hard drive. I used no security levels on the erase. As I hoped, this also reset the WD hard drive. The erase only took a minute. Then I clicked on the drive and on “Get Info”. (Right click on WD icon). In the Get Info window, you can select permissions again. I also had the option of “ignore permissions” which I checked. I then renamed the WD drive, clicked onto Time Machine and it appears to be working. It’s backing up now.  

I’ve got to say, this hassle was very discouraging. Apple stores were pushing this brand, and one would hope it was a good piece of equipment. I’ve had mine for only a little over a year. Of course the warranty is expired. Unless WD pro-actively resolves these sorts of issues, and provides customers with fixes, I won’t be buying another one. 


#4

Hi there,

I’m having pretty much the same problem with my external HD, have tried to change the permissions on disk utility but it was greyed out too.

I haven’t got another HD so, is there any other way I could fix the problem?

Thanks