My Book World (Blue Rings ITB one drive (B) damaged due to do i get data

My Book World (Blue Rings) 0. size 1 Terabyte. Two 500 GB hard drive. Dur to serge One (DIVE B) is failed Dive A is show folders but when we are trying to access we can access folders. It is asking for the permission. Even we tried to update permission from WD anywhere we can’t access the drive.

How do we get the data?? I tried to take out drive and install of desktop computer running windows XP, it show s the drive in CMOS setup but we can’t see the drive in XP …when we check the drive management we can see the drive but with unknown partition.

Is there any way we could access the drive and get our data(almost 5 years data??

The only suggestion you can have to recover the data is to take the drive to data recovery company or try using a data recovery software to see if you can get your data back.-

Do you suggest any data recovery software???

To be honest with you… I haven’t recover data on any of my drives (thanks God), that’s why I don’t know exactly what data recovery software is good or not and I wouldn’t like to suggest a software which I don’t really know how is going to work.

If you had a RAID 1 (Mirror) then you’ll just need a Linux computer (Fedora 14 is best) as the file system of the drive is EXT3, which Windows doesn’t read.

If you had a RAID 0 then you’re out of luck and a software won’t help you, you’ll need a recovery company if this is the case.

Thread moved to WD Network Products: My Book World Edition.