My Book Won't Show As Drive, Nor Can Erase

Couple of weeks ago my MyBook just stopped working. It stopped appearing as a drive. Went to Disk Mangement and it said it wasn’t initialized. Tried to and it wouldn’t start. Always got an error message saying a fatal device hardware error. It shows in the WD apps, but its showing it has no space, when I know it had tons of it left. It was also telling me it was locked and I needed to insert my password to unlock. I never had set a password. After the extensive research I’ve done by all appearances I’m screwed, and all the data I had on this thing are basically forever lost. At this point, fine, I’ve accepted it. Went to try and erase the thing, factory reset and redo everything on how I handle/use this thing and low and behold, I can’t do it. “An exception occurred during the operation, making the result invalid. Check InnerException for exception details” is what I get when attempting to erase the drive from Drive Utilities. This thing has given me nothing but trouble. Is there anything I can do to reset this thing or do I now have a $100 paper weight?

Hi @Flowone,

As you are getting ‘fatal device hardware error’. This error is most commonly provoked when:

  1. The hard drive cable is faulty. If the cable is faulty, the data cannot be transferred hence the computer prompts the error message.
  2. There are bad sectors in the disk. There can also be corruption and wrong mappings.
  3. If the cable isn’t faulty and the hard drive is showing the same error message in all computers, it probably means that there is a hardware fault in the hard drive.

Also, please be informed that initializing the drive will erase all data on the drive and is not recoverable. In such a scenario, kindly connect the drive with a different known working USB cable and USB port on the computer.

When “the request failed due to fatal device hardware error” occurs, your device turns inaccessible. This error usually occurs while attempting to transfer/copy files and suddenly the Windows OS fails to recognize the input or the output devices. In addition, this error could also be due to a fault in the systems hardware, inappropriate configuration, loose connections, etc.

To fix the error you can try the below DIY methods:

  1. Check the SMART status
  2. Run an error check
  3. Run CHKDSK scan
  4. Initialize the disk

Further, you can check the below blog to know more troubleshooting methods that can help resolving the issue and also helps to recover data from such drive:

Hope it helps!

I have the same problem, the disk needs to be returned