My Book USB 3.0, 3 TB drive prevents my computer from rebooting!


#1

I have this drive formatted as NTFS under Win 7 Ultimate 64bit.  It has a single primary partition on it.  It is connected to my computer via a USB 3.0 port (my motherboard is the Asus P8P67 Deluxe).

The drive seems to work fine and I have no issues when in Windows.  However, if I RESTART windows, I get a boot up error essentially saying that I need to provide a boot drive - in other words, the system does not recognize my internal raid0 array that contains the system and boot partitions for Windows.  This only happens when I RESTART.  If I disconnect the USB drive from the computer, my system boots up normally.  Also, if I choose to SHUTDOWN windows then power the computer on again, it boots up normally into Windows.

Anyone have an idea why this drive is hi-jacking my system on bootup during a restart?

By the way, I checked and double checked my EUFI boot order - even when I disable all other options and just leave my raid0 array as the only boot device, I still have this problem.

Help!


#2

I can see you’ve tried almost all the options.

Some Asus BIOS boot setting has two options to set. (You need have your external connected at this time)

1)      Boot order (List of devices that can be ordered take proceeding over other devices in boot sequence)

2)      Bootable HDD devices (In this list you can remove all the HDD’s during the boot except the one you need)

I have a doubt that since you are using Raid set, it is possible that Raid set may have lower priority over external devices. Best bet is to address your issue to Asus forums. Look for BIOS updates addressing this issue.

P.S. Latest BIOS update for your mother board is Ver. 1053. Read the info and you can update to that version if haven’t done that already. But none of the BIOS updates, hasn’t addressed your issue.

Mabikay

Note: Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the ‘Accept as Solution’ button for the post that solved your issue.


#3

Thanks for the reply.  I have that bios version already and I have also posted in the asus forums.  funny thing is, my bios has no option for including the external drive in the boot order (yes, it is connected at the time).  I suspect you are correct in that it has something to do with the fact that I’m booting from a raid0 array instead of stand alone drives.

I will keep my fingers crossed that I get something from the asus forums.  Thanks for the quick reply!


#4

With help from the Asus forum, I solved the problem.  The problem was not with my WD drive at all - it was due to the motherboard trying to boot off the USB card readers in my monitor.  Once I disconnect the USB cable to my monitor, the problem does not recur.

Sorry for blaming the WD drive, but that was the only “real” drive I had connected to my system.