My Book Unlock "CD" not seen by Win Explorer

I have had a couple intermitent issues with myMyBook USB drive for some time, but now they seem permanent.

  1. After every reboot, the drive is locked and the Unlock “CD” is declare not available by WIndows (7 Pro 64 bit), but can be accessed just fine by Free Commander, ZTree and PowerDesk. After using one of those file managers to launch Unlock.exe, the drive is accessible, but the “CD” (drive Y in my case) is still not available in WIndows Explorer.

  2. The desktop Icon for the same drive seems to have been replaced by a generic Windows file icon. Any attempt by me to change the icon fails (the process seems to work, but the icon does not change). This is the only Icon (out of about 40) on my desktop that does this.

FWIW I have a WD SATA hard primary HD, a WD Hybrid internal drive, the WD My Book in question, a WD Essentials “pocket” USB drive and a MyCloud Home Duo - and all the other WD products do not exhibit these issues.

Neither issue is a major problem, but I would like to know the cause. Any ideas?

Hi MrC1946,

Well in this case, you can download WD Security to unlock the drive and also from that software you can disable the password. So, it will not show you the drive as CD Unlocker. Once you unlock the drive, format the drive in NTFS format. Make sure you keep all the data from the drive to some different location.

Hi Peter,
Thanx for the reply.
I can unlock the drive now, just not from within Windows File Manager. If I left click the drive, I get a message “Application not found” and the only option is “OK”. If I use any other file manager (I have 3 others, ZTree, Free Commander and Power Desk), the disk opens OK. In fact, if I RIGHT click the drive and then click OPEN, it opens OK. Apparently the drive icon is attempting to directly start unlock.exe and is unable to do so (the drive icon has a yellow exclamation mark in it). My question was simply motivated by curiousity.
BTW if I reclaim the unlocker drive and reformat, I assume I lose the lock capabitlity. Is there any way to restore it?
One final, but very important thing - I am SURE some files got erased from the unlock drive. All that re mains are QUickformatter, unlock and autorun (plus two folders, smartware (only contains language files, an ico file) and the EXTRAS folder with an XML file in it.

Update on MyBook Essentials Unlock.exe & icon.

I figured out that the icon wasn’t correct because the ico file was stored on the MyBook drive, and since the drive was locked, that file was not available at boot time. I copied the ico file to the primary drive, and that issue was solved.

I re-read the manual, and found that the instructions direct the user to right click the virtual CD drive and select OPEN, and that does work. I guess the drive was “auto-unlocking” before some of the software was erased. So basically, there are no issues!