My Book Thunderbolt Duo - "Drive was not ejected properly" after waking from sleep

For the first few days, my new My Book Thunderbolt Duo 6TB seemed to work well on the Macbook Air 2012. However, since yesterday, I always get the “drive was not ejected properly” error when the MBA wakes from sleep. I’m not sure what has changed except that I’ve run the WD drive utility once. I tried uninstalling it and the helper program, but neither that nor reinstalling has changed anything.

When I get the error, the RAID is inaccessible and disk utility hangs immediately after launching. After a hard reboot, the RAID works fine once again.

The link below might help, the solution is for firewire based hard drives and you need to use WD drive utility, but it might work.

I don’t see a solution in that KB entry. Of course I can unmount the drive manually before I send the MBA to sleep. But that’s not a feasible procedure for day to day operation. It’s not like we are talking about a $20 USB enclosure for a legacy system here.

I am getting the same problem with one of my Thunderbolt Duos especially when first attached it will eject itself sometimes twice. I too have tried the utikity and everything checks iout fine. It seems to occur more often when it is not first in the thunderbolt daisy chain (I have two Thunderbolt Duos)

Did you ever sort the problem out? i’m having the same issue except it happens randomly.

I seem to have stopped the roblem if not solved it. My two Duos are daisychained with thunderbolt. I swithed them around do that the problem drive was connected directly to my computer and the other one daisychained and since them have not had the problem drive eject itself.

I have 2 Duos and the same problem. Problem stays away if I’m reading from the drives constantly (like playing music from them). Seems to be cuased by inactivity. Pretty bad performance from all new expensive gear!