My Book Thunderbolt Duo and encrypted Time Machine backup


I used my My Book Thunderbolt Duo to store my Time Machine backup on Mavericks.

I installed Yosemite and FileVault is now a default option, so I checked it at install. When I selected the My Book Thunderbolt Duo again for Time Machine backup, it asked me if I wanted to encrypt the backup too, so I said yes.

Unfortunatly, I have an error message saying it can’t use encrypted Time Machine on a software Raid volume, so I had to disable encryption for it to work.

I tried to reformat my volume (Raid 0 - 4 TB) with latest WD Drive Utilities, but it’s definitly a no…

  • Is there a way to solve this ?

  • If no, and because I was thinking about changing my disk model for a new one, does the new My Passport Pro (which is a Raid portable drive) will have the same problem or is it a real hardware Raid system only showing a single volume under the Apple Disk Utility ?

  • If no, which disk choose (no NAS, I want DAS) ?

Thanks for help.

Sans titre.png

Surpriiise ! The Thunderbolt Duo is not a hard Raid volume !


Did you tried to format the drive through the Disk utility? If not, please try that as you will be able to change the RAID on the drive by formatting the unit.

If you need further assistance, I recommend you to contact WD Support directly over the phone or through the email support.

WD Contact info:


Thanks for answer.

Yes I tried with Diskutil, but problem is the same, Time Machine does not accept encryption on a soft RAID volume. I could change to RAID 1 but it would be the same problem.

WD says not to encrypt :,260,436/

But I wanted to know if there was a solution.

Thanks anyway.