My Book Thunderbolt Duo 6TB Won't Mount in Mavericks

I have a 6TB My Book Thunderbolt Duo that won’t mount properly in Mavericks (I’m using 10.9.3, but the same problem existed previously in 10.9.2 and earlier). The issue is present on both a Mac Mini Server (mid 2011) and a MacBook Air (mid 2013). I am using an Apple branded Thunderbolt cable. The same issue was present with an aftermarket cable. I have also tried different power supplies.

A couple of times, the drive randomly appeared for a few hours at a time. Then the system would self-eject the disk and say “Disk was not ejected properly”. Each time it would mount, there was no noticeable data loss.

Now, the disk is almost exclusively not mounting. It doesn’t appear in Disk Utility or in the Western Digital Utlities software. The system profile sees the drive is connected, but the device won’t mount. I’ve attached the screen shot. 

I’ve tried a fresh install of Mavericks, resetting SMS and PRAM, rebooting, disconnect/reconnecting cable, and about everything else. Any idea what is going on here?

Screenshot 2014-05-16 21.11.47.png


As a recommendation, contact WD Support for further assistance on this case.

Were you experiencing the same issues with a different Mac version?

WD Contact info: