My Book Studio LX

I tried to update the firmware on a My Book Studio LX and it acts like its going to then states check cable or connection

which are both fine. I am on 10.7 so is this part of an incompatibility issue ? This is both FW 800 and USB. It will connect and run fine via USB to an Airport Extreme using Time Machine just noticed that new firmware came out after I bought it and now

I can’t update it.

Yup. It has something to do with Lion. WD has not released the patch for that OS yet. Please try updating the firmware on another computer.

Update I did a disk permission repair and it solved my problem or at least I can connect USB via AEBS

or standalone as well as FW 800 and I now have the latest firmware.

Glad to know you where able to sort things out

Both of my MacBook Pro laptops recently stopped recognizing my WD My Book Studio LX. I installed Lion 10.7 several months ago. Anyone know if WD has an update yet and how I can get it installed when my laptops can’t see the WD external hard drive?

Try downloading  Turbo Drivers