My Book Studio II Interface busted


I have a Mybook studio II (1TB : 500GB x2 ) drive that i had been using on my Macbook Pro with Firewire 800 .

The drive worked awesomely well up until two weeks ago ; now when i connect it to my MBP it is not detected or mounted , System Profiler indicates there is an Unknown Device. Nothing in Disk Utility .

Ive tried plugging it into my secondary laptop (Windows 7 ) using mini USB but it still wont get recognized .

The 2 - 500GB drives seem fine , they spin up with no weird sounds or issues , even the light bar illuminates and does its little jig .

From my diagnosis i think the RAID controller is busted , does WD replace these ? cuz my device is still under warranty , i have punched in the serial number and confirmed that .


ALthough, my exernal WD drive is “warm” and seems to be in action, the white light no longer glows, and I don’t think my Mac is being backed up anymore.  Would a somewhat recent upgrade to Snow Leopard be to blame?

my drive was functioninig fine all through leopard and snowleopard .