My Book Studio II 1TB - Raid 0 Status Bad


I have a 1 TB My Book Studio II 1TB in RAID 0, which I use sporadically.

Last I used it the drive was at 100% health.

Today I wanted to access some files but I am getting a red flashing icon from the WD Drive Manager and a bad status.

This is the details:

I have run the Western Digital Data LifeGuard Diagnostics but it doesn’t even see the drive.

Is there anything I can try to resuscitate the drive and recover my data?

I apologize if the solution has been already presented elsewhere but I couldn’t find it through the search function.

Thank you.

Hi, sorry to hear you can’t access your files. Have you tried some basic troubleshooting steps like connecting the My Book power cable directly to the wall? If possible try to connect each internal hard drive individually to a PC motherboard and use DLG to run a test, be sure to place each hard drive back into the same slot. Check the link below for the steps. 

How to test a drive for problems using Data Lifeguard Diagnostics for Windows

1 Like

Hello ichigo thank you for your help.

Yes, I should have mentioned that I indeed had tried all the tips in the pinned post.

I have unfortunately had many problematic drives in the past to know them by heart.

I haven’t tried connecting the drives to the motherboard, a process I am not familiar with since most of my drives are usb desktop drives.

I will research the process and attempt it (I assume I need to buy some cables) and let you know of the outcome.

I hope to have some success since this is a product I received as a warranty replacement, that I filled with my files and never used again until few days ago

It’s total life cannot be more than 10 hours.

Thank you.

Have you tried booting from a Linux Live CD? Sometimes that will alllow access to the drive. I don’t know what kind of luck you will have connecting a RAID 0 setup straight to the mother board. Isn’t the data written across both drives in RAID 0? 


1 Like

Hello Joe_S thanks for your help,

I did think of doing that and will attempt it as soon as I have a minute.

I was thinking too that connecting the single drives to the motherboard will than pose the problem, in case I get anything out of it, that the raid must be rebuilt somehow.

Thank you.