My Book Studio Edition


#1

My Book Studio Edition (1TB)  is not recognized by Windows Xp 64-bit when connected with Firewire or USB .

Help will be greatly appreciated.

Jamel


#2

What kind of Studio do you have? I’ve seen 3 different models… the old studio, the studio-2 (with 2 hard drives), and the new studio with the display…


#3

I have one (1) external HD (P/N: WD10000H1Q-00). It connects through: USB, FireWire or eSATA. I don’t the cable for the latter. I tried to connect with the 2 first cable but unsuccessfully.

Thanks


#4

Have you tried a different computer? Have you tried different cables? Also does the computer make any sound that it see the drive?


#5

Thank you for your reply.

Yes, I tried a different computer. The cables I used work with the actual computer as well as with others. The computer does not make any sound, when connecting the drive. It is was working one week earlier because I did a backup. Due to a crash, I first tried an unsuccessful Restore. Then I reformated the (C:) drive to restore again from the  (external) My Book Studio Edition.  No success. Now, I reinstalled window from scratch but still I would like to restore some programs and data.

Thanks,

Jamel


#6

Connect the drive using USB CABLE.

Check under device manager if the drive is seen.

Right Click My computer->Manage-> in the left pane highlight device manager and check under disk drives if drive is seen( If not check under USB controller, If you see an ! or ? mark right click on it and try updating the driver) If Yes.

Check under disk management.

On the same window on the left pane you will see disk management highlight it and check on the right pane.

Look on the bottom section, you will see disk 1 disk 2 disk 3 and so on, check for capacity of the drive and check if it has a drive letter, if no data on the drive you can try reformatting(format will destroy data). If still not seen try with a different cable and follow the steps again.

Thank you.

IPADDRESS.


#7

If the drive works fine on another computer then issuse with your OS. If it does not work with another comptuer then issuse with the drive. See the link below to RMA the drive.

http://support.wdc.com/warranty/index.asp?wdc_lang=en


#8

So i can see the drive info at Disk 1 but it has no letter assigned to it and there does not seem to be any way to access the drive.  Can anyone help me here?

Thanks,

Michael