My Book Studio Edition II won’t mount on desktop! Help!


#1

Hi, I’m hoping someone could shed some light and let me know how to fix this problem. The My Book Studio Edition II that I’ve been using for 5 months (only) suddenly wouldn’t mount on my PowerBook G4 (Mac OSX 10.4.11). I tried using Disk Utility and I could see the drive and the icon is dim. When I clicked “mount” it still wouldn’t mount, the drive is still showing dim. The WD driver manager also showing the drive in good status and good condition on the menu bar and has the green light. The power light/LED status and activity lights seemed acting normal, it goes in & out when I tried to mount it. And I could hear the sound that normally when the drive is landed on the desktop. However, it’s not there. I tried using different cable - Firewire 400, 800 and USB cable and it still wouldn’t work.

I don’t know if it’s caused by the new Macbook Pro (latest Mac OSX Snow Leopard) I recently purchased. The whole problem started when I plugged the external MyBook HD to the new Macbook Pro to transfer some files, it was working, but then when I plugged it back to the Powerbook  G4, it’s just not showing. I then tried to plugged it again to the new Macbook pro, not showing either. I have the My Book HD configured in RAID 1 with no password at the moment.

I also bought another My Book Studio Edition II HD two weeks ago (don’t know now if this is a good idea now!!). I’m using it with the Macbook Pro with Time Machine. At the moment seems to be working ok. But I’m not dare to plugged it in to the Powerbook G4, just in case it disappear on both laptops. I apologise for the long posting, but I think I’ve coveredd all the issues that I encountered. I hope the drive will come back so I can get back all the data (900MB) in it.

Thanks so much for your help in advance.:smiley:


#2

Hey,

I;m having the same exact problem except mine is the MyPassport Studio II. I had two partitions on mine and all of a sudden my data went missing but the space is still used up on the harddrive. The drive shows up on disk utility but the 2 volumes don’t  mount. Eventually, I had to erase one of the partitions and recreate it and it shows up now, but the other one is still grayed on on Disk utility and still won’t mount. I’ve tried different things, like copying the volume and stuff to see if it will mount but still no solution. I have many many years worth of valuable and sentimental data and don’t want to get rid of it…WD has not been very supportive, shuffling me to their disk recovery people. The disk won’t mount…that’s the problem…there has to be some way to do it.

Anyone?


#3

Try This. I’m using it at we speak

Stellar Phoenix Macintosh Data Recovery is the most efficient and comprehensive utility that ensures absolute recovery in all data loss scenarios. The software safely recovers lost data from HFS, HFS+, HFSX, HFS Wrapper, and FAT file system volumes. It is usable with Mac OS X 10.6 Snow Leopard, 10.5 Leopard, 10.4 Tiger, and 10.3.9 Panther.

It’s $100 bucks but way better than $400+ for data recovery

[deleted - no advertising]