My Book Studio Edition II does not mount on Windows 7

I bought a new MyBook Studion Edition II, 5Tb drive.  I connected it, turned it on and W7 Pro does not mount it – I do not show a new drive on my system.  When I go into Computer Management/Device Mamager, I see the drive, and when I switch to Computer Management/Disk management, I see it also, but without a drive letter.  (It shows as 3 partitions, 200Mb, 5588.7- Gb, and 128 Mb.  All healthy.)

But nothing I do makes the disk actually available.  I’ve tried with both USB2 and Firewire 400.  I’ve tried uninstalling the driver using Computer Management/Device Mamager and reconnecting it and lettingt he driver reinstall.  I’ve rebooted it and made sure I’m up-to-date on Windows Update.  All no luck. 

Any suggestions?

This drive comes formatted for Mac. It will need to be reformatted to NTFS for Windows to use it…


That does not seem to be the case.  When I look at the drive in Computer Management/Disk Management, the drive shows as “healthy” with a blue bar which the WD documentation says indicates that the drive has been partitioned and formatted.

you need to go into disk management and delete the partition.  There is something in the knowledge base on it.

Any idea what?  I looked, but found nothing obvious.

Did you reformatt the drive  for Windows? See page 11 in users manual