My Book Studio Boot Freeze Problem Solved

Well guys, it’s been a couple of years since some of the guys who had this older model were working on this problem, and I myself had kind of been procrastinating on solving this. The deal is, I had a Win 7 machine, and this My Book Studio 2TB, 2 things would happen: either:

  1. It would completely power down and be off, and I would boot fine. But then I would boot in and the drive would not be there. Now, from within 7, I could then go back behind my desk and pull the power on the drive and put it back in (essentially cold-booting the drive) and then it would become accessible again. I checked and it seemed like when I did this all my data was always there. I don’t know how safe doing this over and over again was, but…again, for all the times that I did it, it seemed to give me access to my data again. It was just annoying that I had to do this all the time to a drive that was supposed to just work.

  2. The drive would be powered on, but when it was in that state during boot, it made a boot that normally took for me no longer than say, 28 seconds (and it only took my system that long because of my Revodrive 3. For some reason, the Revodrive seems to add 10s to my boot time. When I remove the Revo from the equation, I boot in about 6 seconds) take at least 2-4 minutes. And it wouldn’t be a normal boot either. What would happen is the boot would start, freeze for almost the entire time even before the BIOS post, the drive would blink for the entire time, and then after about 4 minutes the system would go all the way through the boot until I was about to get to the initial windows splash screen, and then it would recycle, reposting through the BIOS screen again and going through another entire warm boot until it got to the normal windows screens. Then I went in and could access the drive.

So, in short, my 2 options were: a) have a normal boot with no access to the drive or b) have to put up with a 4-minute boot time in order to have access to the drive.

Now I looked through all the WD forums, and Google, and played around with various fixes, and I figured out what was happening, at least on my system. I have a DX58SO2 mobo running a 6-core i7 980X cpu w/ 12G 1600MhZ RAM. And what fixed it for me was simply this:

The drive says that it can run at USB 3.0. But it CAN’T. In the end, when I plugged my drive into a non-SS USB 2.0 port, all the problems went away.

What’s even worse is: then I hit my drive with ATTO. And I discovered that not only can the drive not fill the USB 3 pipe, it can’t even come close to filling the USB 2 pipe!! I measured speeds of 35/40 MB/s w/r in USB 3 mode and 30/35 MB/s w/r in USB 2 mode. So it doesn’t really matter which mode you are in.

This drive is dog-slow for me…it’s a shame, because I spent, what, somewhere between $100-$150 for this thing? This was one of the new metal drives at the time and I was hoping for better performance. It wasn’t eSATA, which I was a little disappointed in, but I was hoping for better performance than this! Still, I’m not going to try to get my money back on it, or spend more money replacing it or anything. All I use this drive for is as a data backup and it does still store data, and I’m willing to just…wait for it to do so. I don’t have money to burn to get something newer when this one at least still works.

So anyway, that is the solution. Thanks for reading =)

It would be best for you to clarify the exact model number of your WD My Book Studio. Does it have a screen on the front? If it does, then it is a USB 2.0 unit, not 3.0. if it is the new WD My Book Studio then I’d recommend ensuring the device is running the latest firmware available on WD’s support site. If it still does not perform properly then I’d recommend a free replacement under warranty.


Well, I’m not sure what you mean by “screen”, so I’m going to say that it probably doesn’t have one, but I’m sure that it is supposed to have USB 3.0 capabilities, because it says so right here on the box. Also, my model # is: WDBCPZ0020HAL-NESN. I’ve run the firmware detector, and it says that I have the latest firmware that is available. I have also run both error checks from the diagnostic utility and they are both fine. What kind of performance do you think I should be getting from this drive?