My Book Studio 6TB Problem with Tiger

Good evening,

I’ve just now received the WD My Book Studio Ed II 6TB and installed it on my Mac Book Air with Lion 10.7.2. All runs perfect. I’ve also reconfigured it on Raid 1 and tried moving on it some large data. All was ok. The max capacity showed by WDM 2.2.6 and Disk Utility was (correctly) 3TB. 

After that I’ve installed WDM 2.2.6 on my PowerBook G4 with Tiger (10.4.11) and I’ve tried to connect the external unit on it. The unit start but the volume was not mounted. WDM and Disk Utility are both showing me an unit of 2TB!!! And it remains not mounted. The unit was attached with both usb and firewire 400 cables with the same results.

Of course I absolutely need to use it also with the Tiger Mac. What I have to do? Could someone help me? 

Many thanks in advance, Corrado

Hi, a little news: changing Partition Table from GUID to APM it seems better. The PPC Tiger Finder match the exact amount of space (2,7TB), but Disk Utility still show the wrong space of 2TB!!! Attached on Lion no problem. May I trust this drive…??  

Thanks, Corrado

Wow, many thanks for answer! So I’m adding another question: what’s the differences between GUID and APM? Is it safe to leave my data on actual APM configuration?

Many thanks, Co 

are you sure tiger can read a 3 tb drive?  it might have a 2 tb limit.  also, wd’s wdm doesn’t work on lion, that I know of.  it was last fixed for leopard.

Tiger CAN’T read drives bigger than 2 TB.  As per WD Website:

System Requirements

  • Available USB port, FireWire 800 or 400 port, eSATA port or eSATA adapter card
  • Mac OS X 10.4.10+, 10.5.2+, 10.6.x (Snow Leopard)
    Note: The 4 TB and 6 TB versions work with 10.5.2+ and 10.6.x only. OS X 10.4.x+ does not support hard drives with capacities above 2 TB.