My Book - Stuck in firmware update loop

So after that my external WD drive has been acting up a bit  since I moved from XP to w7 (even though it’s been much better after a w7 reinstall and another revision on my chipset drivers)

I today decided to update the discs firmware in hope that the disc would be more stable and less strange.

I started the update, it recognized my disk and showed me the before and after versions of the firmware, going from 1.032 to one that was over v.3 I think.

Anyway, I choose to update the firmware, the disc got kicked out from (sas/disc mode) to something I guess are a write/update mode for the FW (image 1 below) and then the progressbar started to move, problem being that it doesn’t really seem to do anything, I have no % meter and it only maxes the progressbar, then it starts over, and over, and over.

Image 1

Hopefully the updater haven’t yet to write any data and hopefully I should be able to just powercycle it, but I thought I’d ask here before.

So this is what the application looks like now, sorry for the Swedish but what it says are.

Update you built-in wd software

The update of the discs firmware are running. Do not disconnect either the usb nor the power cable during the duration of the update.

Mybook Elite -------------------------

[Image deleted - Trancer]

Sooo, what to do?



I’m running

  • Windows 7 Pro x64 (as admin)
  • My computer is a dell xps m1530
  • The motherboard uses a intel chipset for the USB controller
  • Nothing else than a mouse plugged in at the moment.

Let me know if there is something else you need to know. I will leave this running for now in hope that I won’t brick the sata->usb chipset.

Update 1.

So I left the computer running for a few hours to come home to this:


"A error has occured while updating the built-in software of the specified drive. Close

all running software and then try to run the updater for built-in software again"


I did as the updater asked me, but without any change, and since the software don’t really seem to be able to update the software, but i keep clicking next until I get stuck in the same “progress bar loop” as in the first post.

I also tried to disconnect the disc and reboot the computer, but now when I plug it in, it directly identifies as the “initio default controller” and the fw updater just goes into the same loop as before. 

Any way to try to force upload a new firmware? Or some way to kick it out from the initio mode?

Update 2


I downloaded the software again and extracted it, and when I run the fresh version of the software (same software, just new download) if gives me error; “Can’t recognize the harddrive model, please contact support”.

I guess this is because the drive is in “initio mode” now and the software can’t find the necessary information provided by the access given to the standard drivers. When I try the first download of the software I still gets to the update loop, this already downloaded the new fw, so I guess maybe it just takes it for granted and let’s me pass the identification screen.

Update 3.

After raging a bit about the situation, I found myself with a million different guides of how to solve problems with external drives (none that actually had the same problem as me). But decided to go with the solution on this site

…not the solder one, but try using the apollo flasher to update. And when i started the apollo updater, the disc didn’t really get updated, but after a while I got an error msg and the drive was reverted back to “hard drive mode” instead of “Initio mode”.

Then out of pure anger and a little bit of stoke that It was “working” (it wasn’t) again I tried the updater again for the MYBOOK drive and now it actually went trough and updated the firmware.

Jolly good!!! was my first thought when the drive popped up in my system with the partitions intact and the data still there.

Jolly indeed until it started to behave exactly as f***king weird as before all this. The drive (the actually usable “hard drive space”, lets call it E: from now on) worked fine until i rebooted my system.

After boot, E: was gone from ‘computer’. The disc manager saw NOTHING of it. In the device manager I found a “mass storage device” that sometimes installed, and sometimes not, I found the sas driver for the disc which seemed to work fine, and then I checked under “disc drives” and it’s only identified as 'disc drive" (where before it was identified as something similar to “WD MY BOOK 1111111 USB”…never really understood what the deal with the 111111’s are).

So after following some tips I found in the sticky thread in this forum I started to change cables, as a last desperate try to get it going again. I had a psu from an old my book (why do i keep buying these? they give me nothing but heartache) but without success, the drive just did the same, “semi-installs” then stops (installs in device manager, nowhere else). Then I tried to change usb cables and ports without any difference (even though I had done this before, of course) but still the same **bleep**.

Measured my wd psu’s just to see that they both aren’t **bleep** but both was ok (without load at least).

And then I finally got one other idea! I popped in my dual usb cable (the ones you will get with 2.5’’ external drives, 2 large usb connectors for your computer (one regular, one +5v) and then a regular mini usb on the other side).

And now I get proper access to the drive again.

So dear WD, please explain this to me.

Is there some funky stuff going on with my computers usb ports? The thing is that my computer has no problem with my audio interface being plugged in, and at the same time a 2.5’’ drive, a passive usbhub (with 2-4 low power hid stuff connected).

Is this some problem with the hardware inside the drives? Is the 5v/500mA in one usb port simply not enough to get the computer to communicate with the controller chipset on the drive?

Is it all a conspiracy to get me really really angry and to make me crush another one of the My book cases to pieces just to pop drive into a stationary computer.

So let me know if you have any ideas.