My Book stopped working! (usb connection issue)


#1

Hi,

After almost 3 years of  good use, something has gone wrong with my My Book!

When I turn it on, the blue light comes on, and I can hear it spinning away, but when I plug it into my computer’s usb port, it just no longer gets recognised.

There was a while when i could fix it by jiggling the cable connection where it plugs into the hard drive, but that doesn’t seem to work anymore. I’ve tried multiple USB cables too.

So the problem seems to be where the usb cable connects to the hdd.

Is there a fix for this? I think the hdd may still be under warranty but I can’t find the receipt, so any DIY suggestions would be much appreciated.

Thanks


#2

Since it’s 3 years old and already had a problem with fit did you try a new USB cable?

Joe


#3

Yes, as I said I’ve tried a couple of different USB cables, so I don’t think it’s a cable problem - I think it may have something to do with the port where the cable plugs into the hdd - in the weeks leading up to the failure, I could sometimes get it to work by jiggling the cable around at the connection point, but this is getting harder to do.


#4

Here’s how I fixed my problem…

If you’re having a problem getting your external hard drive recognized, make sure “Everyone” has “Full Control” access to the drive.

Open “My Computer”, right click and pick “Properties” in the context menu. Then select the “Security” tab. Once that is up, click the “Add” button, enter “Everyone” in the field provided, hit “Apply” then “OK”… and you’ll be good to go.

Hope this works for you–good luck!