My Book sometimes auto disconnect

Times to times my external drive auto disconnect, should I replace the power cord or the usb cord? Or both? What’s causing the problem?


It is good to try out different USB cables and power adapters if the drive uses power adapters, to make sure you can narrow down the cause of the disconnection.

Mine does too. What OS are you using. I’m on Windows 10

Same or similar problem here. My Book Duo USB 3.0 (2x 3TB configured as RAID 1) kept dropping off the USB connection. Here’s my troubleshooting log:

Product will not stay connected via USB – neither 2.0 nor 3.0.
The drive functions properly when first powered on, or when the USB cable is disconnected and re-connected, but continues to “drop off” the USB connection after several hours to a day or so. When it is connected, all backups function properly. It is configured as RAID 1 (Mirrored) running Continuous backups.

It is installed on a Dell Inspiron 580 / Windows 7 Home Premium SP1 with all current updates.
The PC’s BIOS and drivers are up-to-date.
The My Book Duo is powered by its AC adapter plugged into an HP surge protector (along with PC tower, monitor, and 2.1 sound system). I have tried plugging it directly into a wall outlet – no change.
The My Book Duo is connected to one of the rear USB 2.0 ports (Intel 5 Series/3400 Series Chipset Family USB Enhanced Host Controller - 3B34). I had installed a new Inateck PCI-E 2-port USB 3.0 card in my system, but it experienced the same problem so I uninstalled it and went back to the built-in 2.0 ports. I have tried different USB ports and cables - no change.
The Control Panel > Power Options > Plan Settings > Advanced Power Settings > USB Settings > USB Selective suspend setting are set to Disabled for all power plans.
All latest firmware, WD SmartWare and WD Drive Utilities are installed.
Tried uninstalling WD software and using only Windows backup utilities, but same problem – drops off USB.

When first powered on or the USB cable is disconnected/reconnected:
Power light is on and blinking; both drive lights are off (mostly).
WD Quick View shows “Drive Name [Volumes]: My Book Duo USB HDD [M:] / Used: 36% / Locked: No / Temperature: OK / RAID Status: Healthy”
WD Drive Utilities ( shows the My Book Duo as 5.46 TB, RAID Status as “Healthy,” and Drive 1 Status and Drive 2 Status as “Online.” All WD Drive Utilities are available (none are grayed out).
Drive Status Check and Quick Drive Test both pass.
CrystalDiskInfo reports the drive’s Health Status as Good and the Reallocated Sectors Count is 0.

Symptoms when it drops off:
Power light is on and steady (not blinking); both drive lights are off.
WD Quick View shows “RAID Status: Unknown”
WD Drive Utilities ( & tells me to “Attach a supported WD drive.” Then, when the tool opens, it shows the My Book Duo as 0 Bytes and displays RAID Status as “Not Configured” and Drive 1 Status and Drive 2 Status as “Empty.” Only the RAID Management utility is available (others are grayed out).
If I try to open it with Windows Explorer, I get a pop-up window titled “Location is not available” with the message “The request could not be performed because of an I/O device error.”
CrystalDiskInfo cannot even see the drive.

Per Tech Support’s suggestions:

  • Checked power converter/cable and enclosure for excess heat – not excessively warm. (While My Book Duo was still connected and performing backups, max temperature reached was 53C per CrystalDiskInfo monitor. That is acceptable.)).
  • Tried on another computer (Dell Latitude D830 laptop running Win 8.1 and Win 10) – same problem.
  • Tried different USB cable – same problem.

Finally had to request RMA and get replacement unit. It’s working fine, NOT dropping off USB.

Happy ending.