My Book Office Edition 1TB Disappeared on Yosemite

Since upgrading my mid-2011 27" iMac to Yosemite, my 1TB My Book Office Edition has been acting snarking.  First the music I play in iTunes which is located on the drive was starting/stopping.  Then it was causing Yosemite itself to act quirky (laggy, crashy, etc.) and then the drive disappeared entirely.  After rebooting in Safe Mode and repairing permissions, it came back.  This happened 2 or 3 times.  Now the drive has disappeared again.  The blue light on the front is moving up and down as it normally does.  If I shut the drive off, I get the improper eject warning from Mac.  However, I cannot “see” the drive in Finder.  I tried switching out the cables and tried unplugging my other 2 external drives all to no avail.  Thankfully I have a Time Machine backup of the files however I am perplexed at the problem.  I suspect that the issue lies in the driver, such as it is, is not compliant with Yosemite.  Anyone with any suggestions would be most appreciated.

Welcome to the Community.

On such cases it is recommended to use Mac OS’s built-in Disk Utility in order to test and diagnose the hard drive. There are times when the file system is corrupted or in need of repair before Finder can mount/access the storage volume. I would also recommend changing the USB cable: