My Book not connecting to Windows XP

Hi all,
I’m using a set of Windows virtual machines in my iMac, one of these is a Win XP. I’m able to connect properly my My Book to Win 7 and Win 8 VMs, but not to Win XP. There’s no support in XP for USB3, so that’s fine, but I’m expecting the disk to be recognised as a USB2 device, as it should be “compatible with USB 2.0”. This doesn’t happen, and connecting the device results in an error message saying the device has not been recognised. Any suggestions? Thx!

What’s the size of that unit? Hard drives larger than 2TB are not supported by Windows XP.

Hi Trancer, My Book it’s 2TB.

Try replacing the USB 3.0 cable with a USB 2.0 cable in case there’s a driver issue.

Yes, I already thought about that solution, but as you know My Book has a USB3 cable port

You can use a Micro USB 2.0 cable in the USB 3.0 connector. The flat (Top half) section allows you to, leaving the square (Bottom half) of the connector empty.

Trancer, you’re great! :smile:
That worked! As soon as I connected the drive, although I could see the drive in explorer, I had an error message saying a WD SES Driver was missing… Downloaded from WD website… DONE! It works now!!!
I didn’t know that a Micro USB would have fit… :grimacing:
Thanks a lot, you got a beer :smile:

My pleasure.