My Book Not Being Recognized (Windows 10)

I had worked on my laptop last night and this morning my laptop is no longer recognizing my external HD. I have gone under the Device Manager and the Devices/Printers and it is shown in the list. However when I go to Disk Management it says that it needs to be initialized and its space is unallocated and not being recognized as the E: drive I assigned it on my desktop. I have about 700GB of backed up data saved on it and cant afford to lose it.

I’ve tried uninstalling the drivers and switching USB ports but still not being recognized. The external is still making noises like it would if it was being accessed. I do have a desktop computer that is currently packed,(In the middle of moving) would that also be unable to access the external? Both of my machines are running Windows 10


Sounds like the unit lost the partition. As a recommendation, try using a data recovery software to see if you can get the data out of the drive.

I just bought a Windows 10 PC and it could not find My Book back up external drive as well. Previously, I had a Windows 7 PC. I found out that I had to unlock my My Book drive under Backup settings and then press previous version Windows 7 to back up. All is working now. Windows 10 has changed back up options and will not work unless you unlock your My Book first. Hopefully, you remembered your password to unlock it. It gives you a hint.:wink:

1 Like