My Book no longer is recognized by my Mac


#1

My External hard drive, My Book, is no longer recognized by my mac.  It has worked before, but, now it doesn’t come on.  I have changed cords, ports, power sources etc. and it still doesn’t.  Is there any way to retrieve the what is on the disk?


#2

When you say “now, it doesn’t come on”, you mean the drive is dead not just that it won’t mount, right?


#3

I’m having the same exact issue. My drive was once recognizable, and now it is not. I thought I had a faulty cord (i had disconnecting issues before this issue) and I just bought a new cord and NOTHING. The light on the drive flashes but it wont mount.

WD, do you guys understand how infuriating this makes me as a customer?

I’m a photographer and videographer, I have someones wedding pictures on this drive, there is NO PRICE on the info stored on this drive.

If i don’t find a solution quick, I will turn everyone away from buying your products. (i’ve waited over 3 days for a response to my email to you guys) what a joke.

Nick


#4

This is just a users forum not a customer service area. People try and help if they can and don’t post if they can’t. There aren’t that many knowledgeble Mac users here.

Joe