Regarding my previous massages about the lost files on one of my ‘My Books’ that Windows could not see, I’m delighted to inform everyone that the latest firmware update has fixed the problem. I can now see all the files, including the files that the data retrieval program reported as empty folders. I took a chance doing the update, as the drive was not working properly, but after copying most of the files I decided to try it, and in my case it worked. So, try it, at your own risk of course. :slight_smile: :slight_smile:

Glad the firmware update worked for you.


I want to make sure I’m understanding your post.

My computer (windows 7) is no longer recognizing two external drives; both of them WD.  One of them is My Book 5000.

They are connected by USB…and I know the ports are working.

Are you saying you did a firmware update and then could see your drive AND your files?  The update did not erase anything?

You say “after copying most of the files” your tried it.  If your compute was not “seeing” the drive…how could you copy the files?  This is what is confusing me.

Thanks in advance.


Don’t get to exited about this. There is nothing in the firmware updates that would make a drive suddenly become operational. Most likely the firmware update process reset the SAS and/or USB driver.