My Book Live wont show all photos

I ahev used my 2tb My Book as a backup device and rather than duplicate the files I have used ssh to access the device and symlink the directories to the Shared Pictures directory. Now it only displays some of the photos when I access them from my Android phone using WD Photos, however WD2Go on the phone correctly displays all the photo directories. Noe the backups created do have some images other than jpg and png format and a few other files. Surely the database build should ignore files it does not support and should complete the database build, after all the summary screen shows 94000 photos but WD Photos say thare are only just under 2000.


Been checking my actual file numbers in the directories as compared with what the Media Status says and they dont agree, in the case of the photos it thinks there are 1000’s more than there are actually there. Also I dont now have any symlinks to the Shared Pictures directory but it still finds them. I never had this much hassle with my previous devices using DNLA.


I’m confused – you’re talking about two different things as if they were the same. 

DLNA and WD Photos have nothing to do with each other.

So is your issue with DLNA or WD Photos?

If it’s with WD Photos, after making changes to the file system (changing symlinks, etc) I would recommend you rebuild the server  (The MBL actually calls it the WD 2go server, but it’s the same thing.)

Sorry but I assumed obviously wrongly that WD Photo was a dnla client. Anyway no matter what I do and I’ve tried lots WD Photo wont work correctly and only finds a subset of the photos I connected to the Shared Pictures directory.

On the dnla side looking at the stats on the My Book web pages under media the totals for photos are meaningless when compared to what I actually want it to show as photos, far more than I have uploaded. Maybe I misunderstand how this works, I assumed that for the server to display photos, video and music via dnla they had to be found under the appropriately named Shared xxxxx directory. I did not think it searched and indexed the entire contents of all files under the Public directory which is beginning to be what it looks like. As I have it setup as a straight forward backup device I have loads of bits of video which are copied directly from my video camera, it is pointless having these accessible via dnla for example. I have tried rebuilding and rescanning but it does not seem to come up with the correct totals.


OK I think now I have taken another look the dnla server does not do what I want it to. I did not expect it to simply index the entire drive for stuff to serve, I want a system which can be customised to serve only the files I want and not anything on the entire 2tb of data (when its full).

So is there any way I can get it to do what I want? Just select the music, photos and video that I want it to serve? To my mind it should either have predefined directories (which is what I thought it had and confused me) or it should allow you to customise which folders to scan.

As for WD Photos it just plain does not work, even with nothing in the Shared Pictures folder it still thinks there are some photos there!