MY Book Live won't boot

It just stays stuck with the yellow light and makes a sound like if trying to read something, but doesn’t got to standby mode (green light). Therefore, I can’t access it in anyway to try to configure it… I tried holding down the reset button with no results.

I just remembered that I tried to delete the “Software” folder in the “Public folder”. I might of deleted some files, but not all of them as I got a forbidden permission alert. However, my hard drive worked fine for several hours after that. 

Please help!

I do not have ‘Live’ (yet)… but this thread can give yuou some info -

Well someone managed to delete the “software” folder and doesn’t seem  to have any problems. This might not be the issue.

I am still stuck with my HD with the yellow light, I left it on all night. It’s still making a noise every few seconds like it were trying to read something.

I’ve only had this thing for a couple of days. It doesn’t really give me a lot of confidence to replace it for a new one, really…

Any other suggestions?

The YELLOW LED indicates the OS is loading.   If it never gets past that, then it must have a corrupt image in FLASH.   You need to replace it.

The MBL is rock solid for me; I don’t think you have any risk in replacing it.

Deleting the “software” folder under the Public share will have no impact to the device itself.  The software folder contains all the files that are on the physical installer CD.  The idea is if you lost your CD, you can burn a new one from the files in the Software folder

TonyP is correct.  If during the boot up, the LED goes from blue LED to yellow, then stays at yellow, there is something wrong with the boot up process. Normally it will go from blue to yellow then green.  Or if something is wrong, the LED will turn up red.  Right now, it seems it cannot even get to Red or Green.

Unfortunately, without the device I cannot provide additional support.  From your post, you seem to have tried all troubleshooting steps. e.g power off and on, reset button on back of the unit.

Contact WD Support and request an RMA if conveniently possible.