My book Live unable to set up

I’ve been using My Book Live 3tb for a number of years successfully. I recently upgraded my OS from Windows 10 pro 32bit to 64bit. When I reinstalled the software I could not set up the drive with the set up utility. It recognises the drive and the IP address but when I click next and come to the screen "checking your device…"the following error comes up:

“We’ve detected that you may not be able to… Configure the device (settings, etc.)”

I tried it on another computer and get the same error.

Windows network recognises the drive.

When I put the IP address into a browser (access the dashboard) the page doesn’t load. Also there seem to be two IP addresses depending on what I’m looking at. My router login says it is but windows and the WD programs say it is

The front light is a solid green.

I have done the whole four second paper clip in the back reset and nothing changed (other than erasing all my data, which I expected).

In WD smart ware the drive is recognised but I can’t log in to it.

What do you think is the problem here - the drive seems otherwise fine (although I can’t do anything with it yet)?

That’s an APIPA address. That’d be wrong for your router to report that – Routers CANNOT assign APIPA addresses.