My Book Live Samba crashes

I have the problem described in this thread which describes how the /tmp directory fills up and causes Samba to crash. This problem needs urgent attention to fix it as it keeps on happening on my 2TB My Book Live. This is unacceptable for it to still be outstanding for so long with no permanent solution.

Can someone please explain why this is and what is being done about it?


My MBL has been up for over two months, and my /tmp filesystem is only 5% used.

MyBookLive:/tmp# uptime
 09:28:49 up 63 days, 9:05, 1 user, load average: 1.47, 1.46, 1.39
MyBookLive:/tmp# df .
Filesystem 1K-blocks Used Available Use% Mounted on
tmpfs 102400 4992 97408 5% /tmp

… so the curious question is … why is your /tmp filling up so fast?

I don’t have any of those JPG* files at all.

If you’re still seeing them, and they’re open, an lsof will indicate what process is generating them…

The problem seems to happen whenever I add photos which then get added to the DNLA service I use via the My Book Live. Backing up normal files does not usually cause this so it would seem that it is the DNLA servcei which causes this to fill up /tmp usually with 3 large JPG* files.

As I said this has been known about for some time and I am surprised and concered nothing has been done to fix it permanently.


I just uploaded 44 photos and immediately it crashed after the upload completed so this has to be related to the DNLA server stuff…


These JPG files are huge

-rw------- 1 root root 32766720 Jun 24 06:32 JPG1vKQpZu
-rw------- 1 root root 32766720 Jun 24 06:32 JPG25JQPKu
-rw------- 1 root root 34734080 Jun 24 06:32 JPG31GfCvu

and are owned by a process called dms_smm. So it looks like the tmp fills up but Samba is an innocent victim.

This problem happens whenever I backup photos to the device and the media scanner has to run to scan for new files. I have over 55000 photos on the device and want to be able to use it to serve out these photos to tablets on my local lan. Yesterday I recovered Samba by deleting these files and restarting it but no new photos were added to the database. I tried to rebuild the database from the web interface but the problem recurs with these files appearing and crashing Samba.

So can someone please explain why this is happening? I do have the latest f/w installed on my device.


If I had to hazard a guess, the dms_smm process (which is, indeed, the junky DLNA server WD started using in lieu of Twonky) is hanging or abending and not cleaning up after itself.

As to WHY it’s doing that, I have no clue.

Options:   If you don’t care which DLNA server you’re using, load the WD firmware that has Twonky instead of Access DLNA.

Well where would I get the Twonky level of f.w from?


Thanks for the pointer to Twonky.

Since disabling the WD DLNA server in MBL I have not had any crashes due to these large files being left. So I can only assum it is the built-in server which is at fault. I do expect WD to try to resolve this issue because it makes it impossible to run the server.

As to Twonky it seems to work well. However the issue I have is that on my Android devices I am as yet unable to find a DLNA player which works acceptably with Twonky, What do folks here use on Android devices, please be aware my primary use is to access my photo archive (over 56000 photos) on Twonky and not play music or video. Of course the WD Photos app does not work with Twonky.


Any particular reason you’re required to use DLNA instead of an ordinary file browser?

Its for my wife’s benefit to browse the photos. Using a file browser is slower and she has to negotiate the file structure to find the photos which she will not remember. Using DLNA she can just see them more easily and quickly.

Also in my view the DLNA server in MBL should work without causing crashes. Lets face it you dont buy a new car and have parts of it not work. So WD needs to resolve why their server code causes this problem and fix it. WD Photos on the tablet worked fine but of course with the server causing these issues it is just a piece of junk at present as it wont work with Twonky

I have now found an Andriod App called BubbleUPNP which seems to handle the photos OK, all the others I’ve tried wont show everything in a particular folder even though in a web browser on a PC Twonky displays them OK.