My Book Live reset button problem

Hey all, 

After having a 1gb My Book World for a couple of years, it started to get a bit noisey.  So I decided it was time to upgrade and picked up a 2tb My Book Live a couple of months ago.  

I filled it up with all my important stuff, and was very happy with it.  I even considered backing it up, but thought - neh, it’s only been 2 months, it’ll be fine for a while.  

Earlier this week, I needed to move the device.  So I shut it down from within the web UI, unplugged it, and gingerly set it back up in another room.  On plugging it in, after the yellow start up light, I just got green flashing and the drive sounding like it was working hard.  It no longer appeared on the network.  Uh oh.  

I left it for a while, and after a few hours the light settled to green with just the occasional activity flash.  But it still wasn’t appearing on the network (the WD software didn’t detect it either).  

I looked online and saw that other people had resolved similar problems by holding the reset button for 4 seconds and unplugging the power.  I poked a cocktail stick through the reset hole, and something seemed to move inside.  Mysterious.  Upon more poking, I noticed that there didn’t actually seem to BE a reset switch in there.  I had no choice but to pull the plug (since I couldn’t access the UI to shut it down, or press the non-existent reset button).  

When I picked up the device, I noticed a new rattle.  So I took the ill-advised step of removing the case.  Inside, I found that the body of the reset switch - which incidentally only seems to be supported by it’s little solder legs - had bent back on the board.  This had freed the tiny round reset button to rattle around in the case.  I tried putting the reset button back into the switch body and bending it upright - but it still didn’t work.  

I’m now in a panic.  The drive contains thousands of irreplaceable photos which I KNOW I should’ve backed up - but I just didn’t get round to it.  

Is this the end of the drive?  Is there any way to reset the device without this switch?  Is there any way to get my data back?  

If anyone has any advice (aside from “you should’ve backed it up,” or “you shouldn’t have taken the cover off”, it would be much appreciated!  



Well, taking the cover off was the only way for you to discover the problem, so no sermon there… :wink:

I kinda doubt it’s dead.

Green is the “normal” color for the LED, whether it’s flashing or not.   Green just means the drive is “awake.”  

Blue is OK, which means the drive is asleep, but online.

Yellow and Red both have different meanings, all explained in the manual.

At any rate, chances are your drive and data are still OK.

If you were using a static IP address, and you remember what it was, let the drive boot to the GREEN LED then try “pinging” that IP address.

For example:


Pinging with 32 bytes of data:
Reply from bytes=32 time<1ms TTL=63
Reply from bytes=32 time<1ms TTL=63
Reply from bytes=32 time<1ms TTL=63
Reply from bytes=32 time<1ms TTL=63

Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

 You should see “REPLY.”

If you see 


Pinging with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss)

 Well, then you’re in a pickle;  the proper way to recover from that condition is to use the reset button which is no longer an option for you.

If you had the drive configured to use a Dynamic (Auto or DHCP) IP address, then look in your router (or whatever acts as your DHCP server) and see if it will tell you what the IP address is that it assigned to the MBL, and repeat the above with that IP address.

If you do get positive PINGS, then you should be able to browse to that IP address directly in your web browser, by using the address (from my example above)

and get access to the Webpage for the MBL.

If *that* still doesn’t work, I’m afraid you’re probably out of luck.

If that’s the case, then you have a few options:

1- Get your drive replaced under warranty; your data will most likely be lost.

2- Send your drive to a WD-approved Data Recovery Service; they will recover your data and either arrange for the replacement, or send your data in some way and send you back the dead drive for you to replace with WD.

3- VOID YOUR WARRANTY – Take the drive out of the case and attach it to your PC and get the data off of it.

If you elect to do number three, there’s a handful of posts in this forum about how to do that.

1 Like

Thanks for this Tony.  I tried pinging the drive, but didn’t give a response.  As far as I recall, I’d set the DHCP server on my router to give the MBL a fixed IP - so I used that.  The router isn’t showing the MBL or any extra connections, so I guess the drive just isn’t getting that far.  

I’ve sent a support request to WD, but I’m not holding out a lot of hope that this is something they’ll be able to fix by e-mail.  I’m also not keen on sending it back for repair, as I doubt they make any guarantees of trying to keep the data (assuming they’d even accept it since the case has been off).  

I’ll wait to hear back from WD on the off chance before doing anything else, but I have a feeling number 3 might be the only option.  Wish me luck!  

Thanks again for your advice!