My Book Live No Longer Found / Accessible (Mac)

We’ve had our MBL for 2ish years and it’s worked great until this morning.  I tried to back up via Time Machine today and for no apparent reason the drive was no longer accessable, nor was I able to “see” it from either of our two computers.  

I’ve tried resetting the computers, unplugging and reconnecting the MBL drive, and resetting the MBL to factory settings… all to no avail. 

Also, unfortunately, the LED light on the front of the MBL died a year or so ago, so I also have no idea what it’s trying to tell me via the color / flashing / etc… 

Anyway, I’d appreciate any suggestions, as I really don’t feel like dropping $ on a new backup drive.

Thanks in advance for your help.

FWIW, I also tried new ethernet cables to / from the router.  

I hear it running when it’s plugged in and, while the LED light on the front is out, there are green flashing lights on the back where the ethernet cord plugs in.  That said, I still can’t see the drive or find it anywhere.

Anyway, again, if you have any suggestions I’d really appreciate it.