My book live never sleeps

Add me to the list of disappointed new MBL owners that purchased a new MBL, put little data on it and it slept as it was supposed to until I upgraded the firmware before it was pulled (wish I hadn’t) and now the only way to get it to sleep is to disable remote access. Unfortunately the main reason I bought the MBL was for remote access use. UGH. Very surprised at the lack of timely action to fix this problem by WD. Now all I have is a second Time Machine until WD gets it together. I have been a loyal WD user/customer for over 15 years and spent lots of dollars on WD products. Just not use to seeing an obvious issue go unchecked with firmware that provided a “step backward.”

1 Like

So is this an issue that has been caused by the new firmware. I happened to notice my 1tb MBL go to sleep today only for the light to turn green again 1 second later. None of my devices should have been trying to access it. There’s no point disabling remote access because it’s the devices main raison d’ etre. Starting to think WD write buggy software.

I got a 3TB My Book Live a couple of days ago. Loaded with about 700 GB of movie files and some miscellaneous documents. No photos. No music.

All remote access is turned off. No FTP. No iTunes. No Twonky. No web access. No timeserver. 

Unit has never gone into sleep mode voluntarily, although that feature is enabled in setup.

Even with the Ethernet cable unplugged from the unit, it is still making disk access noises (like a scratch and then a little thump) about every 15 seconds. After several minutes, the hard disk spins down.

Please help! FIrmware version is 02.32.06-006 : Core F/W

that’s a lot of info, just give it a few days to finish

cman548: I assume you were referring to my 700GB of movies? But I do not have Twonky enabled, so if I understand correctly, it should not be scanning or whatever.

I found that if I put all of the computers on the network to sleep (or shut down), then after several minutes the MBL would also sleep. But if any of the computers mounted the MBL, then the MBL will not go to sleep again.

Hello.

I am new to this forum, as I am currently doing some “research” to decide which NAS I will buy. One of the options is the WD my book (duo), but as I read this thread I am not so sure anymore if this would be the right choice.

This is what I do expect of the device:

  • I’ll use it for storing a large amount of photos. I don’t want them to be modified, transcoded or whatever, just stored.

  • I’ll use the DLNA server to access movies from my smart-TV.

  • I’ll use access from outside over the internet to add and access files stored on the NAS.

Considering all of the above I have a central requirement for the device:

All the necessary services to provide the functionality listed above need to be enabled all the time. But whenenver I don’t use the service (meaning e.g. no smart-TV is really reading the content of the NAS or I do not actively pull or push files over the internet) the NAS reliably needs to go to idle mode and only wake up when there is an active access from a device.

With this in mind, would you say the MBL (or the DUO) is really the right device for me? If not: would some other manufacturer have a NAS it its portfolio to satisfy my requirement?

Thank you for your feedback.

Hi,

I’m suffering from the same problem and am trying change my rescan, however when I enter http://192.168.0.10:9000/config  in my web browser I get page not found.  Any suggestions?  Thanks.

Actaully, I realise what the problem was.  I did not have twonky enabled.

After turning off twonky, itunes, etc. My log files showed ~ 20 minutes of inactivity, after ~ 10 minutes of activity. This suggests a program activating every 30 minutes and my drive going standby after ten. I tried turning off avahi-daemon, no help. I tried turning off monitorTemperature (30 min cycle) no help. I finally turned off samba. Now MBL goes several hours between awakenings. I set #shutdown -r 03:01. ramlog writes at 03:00 and if any other process is on a 24 hr cycle, hopefully they’ll do r/w at the ~ similar time. I will also look at my dhcp server to ensure that renewals are also done at ~ 03:00, since renewals cause log activity. Tomorrow, I’ll turn samba back on and see what exactly it is reading or writing every 30 minutes. Hopefully I can symlink it to ramdisk.

Sooo, basically the drive will not sleep unless you disable all functions to use it.

Very good, WD.

Okay it’s samba.  Next step: I need to isolate the MBL on another router to make sure its not responding to another computer’s samba stupidity.

My router is also responsible for some activity.  I have DHCP enabled on the MBL (I don’t really need to. I could just use fixed IP).  My router only gives out 24 hour leases, so the MBL (per DHCP standard) requests renewal at 12 hours± random seconds. 

Follow up:

I used

Find -P [every non-empty directory except /proc] -atime 1

Find -P [""] -ctime 1

Find -P [""] -mtime 1

to find which files were accessed/changed/attribute changed in the last 24 hours.  Everything I found was supposedly on the ramdisk (assuming I am reading the results of “mount” correctly.)

hmm.

I stopped the samba madness. It was due to windows 7. I created DWORD HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\LMCompatibilityLevel” and set it to “1”. Per: http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/02476acb-aa5f-4fcf-8079-4a697a065610/ http://www.tomshardware.com/forum/75-63-windows-samba-issue This solved the errors in /var/log/samba/smbd.log and nmbd.log as well as most excess activity. Usually avahi only creates an entry when DHCP is renewed, but sometimes not. Since I don’t use it, I turned off avahi-daemon on my MBLs and Linux boxes. Alternatively, I could assign static IP addresses OR buy/build a better router to extend DHCP lease time and play nice with avahi.

Or was that LmCompatibilityLevel …

try stopping the ntp - time sysnch - that worked for me - it does this EVERY minute - and as far as I can tell it doesn’t matter if the time is wrong - files are given date/time from the writing host - if I could be bothered I would change the settings to once a day - by going in as root with a terminal - look for the secret way in… Only astronomers need the time set every minute!!! I also stopped twonky and the other trawling services earlier, because I am using it as a file store only - I don’t need it to keep indexing. p.s. there is a problem with afp file protections - it seems correctable using a linux pc - set write file permissions to ‘cascade down’ i.e. apply to files within a folder. I didn’t take notes so can’t say the exact solution, but it seems that WD don’t set the permissions correctly for AFP when creating folders/ directories or whatever you want to call them. With my linux system I can use afp or smb, but smb appears to be better (on linux). (HINT: look at folder properties under smb, not available under afp - then change as appropriate)

I’ve had my MBL for about 3 weeks, everything enabled, and it would sleep on no activity.  About 2 or 3 days ago I noticed it was running all the time, that is the green LED was always flashing.  Have been through the posts here and tried several items, to no avail, until I disabled the Remote Access.  That lets the unit sleep.  I’m not pleased with this because that was one of the features I wanted to use.  I suspect the problem is with the latest firmware update, although there haven’t been any updates since I did the one just after installing it.  As I said, it ran fine for a while, then started this running constantly.  Will use it without Remote Access for now.  I guess if I need it I can enable it and let the unit run.  Hopefully WD looks into this.

Someone came up with this solution not too long ago, in case it helps anyone. I haven’t try it yet…

http://community.wd.com/t5/My-Book-Live/Runaway-mediacrawler-The-Ultimate-Solution/td-p/578720

Hi i have the same problem .After installing the new upgrade my NAS not going to sleep . not sure why the miocrawler comes into action

Hi Myron

How to get these logs

I’ve had my MyBookLive 2TB for about 6 months.  It was located on a seperate network in a temporary space until a few weeks ago and I never had any issues with it.  I had everything enabled except FTP and it slept soundly until/unless I accessed it.

Now, I have moved it to another network.  It is on a similar router although the topology is a bit different (a few switches) and there are a number of additional devices (PCs, Printers, WDTVLive, DirecTV DVR).  I have not added any files to the drive since the move but the light never turns Blue - it remains solid Green.

I read earlier in the thread that a few folks have isolated the issue down to the DirecTV boxes.  I have not yet tried unplugging the DVR or other Sat boxes yet.

Any further info on this?