My Book Live NAS says network link down, Windows Explorer can’t reach it

This problem just showed up this past weekend.

I have a WD My Book Live NAS on my home network. From any computer on the network I can reach its dashboard and run diagnostics (which it passes). None of my computers can see it in Windows Explorer, returning: “The specified network name is no longer available.” This NAS is our file server, so losing contact with it is a serious problem. Recent problems with backups mean my backups aren’t current.

Here’s my system:

AT&T router connected by Cat5e to Netgear GigE switch.

Connected by wire to said switch are:

Two Lenovo desktops running Windows 10 Pro, one at 1903 and one at 1909. (Yes, I’ve re-enabled SMBv1.)

One antique Dell notebook running Windows XP Pro, only used to manage backups.

One WD My Cloud NAS that contains backups, currently working okay.

One WD My Book Live NAS serving as our file server, currently not working okay.

All are assigned to the same workgroup.

I can bring up the My Book’s dashboard on any of the three computers without a problem, which tells me it must be connected. I can also ping it. The router lists it and does not indicate an error. The IP address is acquired by DHCP, but has not changed. It has no problem sending me e-mail to tell me the link is down.


On all three machines Windows Explorer says it is no longer available. The dashboard for the device reports that the network link is down. “This PC” lists it as a network location, but with a big red “X”.

I’ve tried rebooting the NAS from the dashboard. I’ve tried resetting it with the physical reset button. I’ve tried replacing the Ethernet cable. I’ve tried plugging it into a different switch. I’ve tried resetting the TCP/IP stack. No joy. I’ve now exceeded my limited knowledge.

Suggestions are solicited. Thanks!

After considerable experimentation I’ve concluded that my My Book Live is actually quite healthy, with one exception. It responds to HTTP, ping and FTP. It sends me e-mail via SMTP. It just doesn’t do SMB any more. Does anyone know how to restart Samba on one of these devices? Rebooting doesn’t seem to do it.

1 Like