My Book Live NAS - BT home hub 3 set up

I have the MBL connected to the yellow GigE ethernet port at the back of my HH3. then i connect to my HH3 via wireless. 

Im a little concerned a smy transfer speeds are only 2mb / s at most  is this normal? 

Do you know what type of wireless you are using? B, G, or, N?

That does seem slow. In order to issolate the problem,  can you plug your computer into another of the yellow ports and see what your transfer speed is then? 

Thanks for the help, much appreciated, this is seriously doing my brain in!

using N wireless. Getting similar speeds from other ports.

Have read online that this could be a Home Hub issue, lots of problems seen by others with the type A, which i have. Have also seen people suggest getting a Gigabit switcher such as…

have tried updating firmware on home hub and my book live, reset both too.

I know what you mean about doing your brain in. There is nothing worse for me than a problem I can’t solve, so I wish you the best of luck for sure.

Here are some ideas… in reality I don’t know what could be causing it though. This might help one of us, or someone else figure it out though.

Perhaps I am missunderstanding you. Have you tried connecting your computer directly to the HH. So that both your computer and the NAS are wired to it. That would eleminate the wireless as being the issue.

I have seen some other posts were people are talking about the MBL breaking their network, like you mentioned. 

Could you try doing an internet speed test like from with the MBL connected, then run it again with it disconnected. This would issolate whether your whole network is affected or just the drive.

with laptop connected directly to HH I get around the same speed again maybe a slight increase to 3-4mb/s

speedtest wise I get 45 Mbps approx when MBL is both connected and disconnected.

Pointing to the MBL possibly?  I also have no problem streaming live tv to my tv via the HH.

maybe port forwarding is the answer? ??

It does look like the MBL is the problem. I cannot image anything else it could be. 

One final test I can think of -

If you connect a network cable directly from your computer to the MBL, reboot them both so they are on the same network, then try the file transfer.

This will eleminate everything… except for your network cable. But even Cat-5 can support around 11MBs.

If it is still slow, you have a defective unit for sure.

If it is fast, then the MBL is not working with your router.

Thanks for the help. Will try connecting MBL directly to laptop via Ethernet in the morning. Will also try various other Ethernet cables I have, maybe this is an issue ?

I really don’t think the cable is the issue. Even if it was, you should see speeds close to 11MB/s.

I was just reading a post about 8 below yours, from TonyPh1234. He is talking about connections that are slow to the MBL. Are you trying these transfers from your Mac or the PC? His post is only relivent to the PC.

okay so im trying to connect the MBL via ethernet cable direct to my laptop. However I cant actually see anything?  not able to view files etc, or even see if the MBL is now connected.

Have been using a windows laptop to connect, as very new to the macbook world. Is there a way of seeing transfer speeds on the mac?

Ive had a look at his post however when i try his solution…CMD net use etc  I get…there are no entries in this list.

UPDATE - Have managed to connect MBL direct to windows laptop via ethernet port. and now…get ready for this…Im getting a wopping 5Mb/s…double what i was getting before but still not what i hoped for.

this was with a cat5e cable by the way.

So I take it from this we are looking at the MBL to be the culprit.

ok, I tried to connect MBL to a friends router, and was getting the same speed, approx 1.5mb this is def pointing to the MBL in my opinion.

Last option is to try thunderbolt-ethernet adaptor on my MAC.

Surely I should be getting faster then 2Mb connection over wireless when my internet conection is showing around 40Mb ?

the fact im only getting approx 5Mb when connected directly via ethernet to my pc is also strange.

Looks like you have it pegged man. It def is the MBL that is the problem. 

With the Mac, I just time it myself and do the math. . . If you are able to do that with your Mac and get good results, then it most likely is a WebDav problem… I will find the post that talks about that.

Take a look at this and see if it explains your problem.

ok getting somewhere at last.

Have managed to determine my wirelesss connection is 72Mbps which is approx 9MB yeh?

for whatever reason im only managing to read data at 4MB from the MBL.

surely if my wifi is cabale of approx 9MB the only thing slowing the speed up is my router or the MBL.

next step is full factory reset of the MBL. If that doesnt improve things then its gonna be new router or new ethernet switch (unsure as to which of these will make the biggest difference.

If you directly connect the MBL to your computer then your speed should be at least 100mbps, which is approx. 11MB/s. There are 8bits to 1byte. Computers generally use Bytes for counting data, where networks us Bits.

If you do directly connect your computer to the NAS, and it does not transfer at least 11MB/s then the problem really appears to be with the NAS. I really would not update your whole network before trying a different one. 

Yeh that’s a fair point, not sure I managed to connect the MLB direct correctly last time though. Will have to do another test, is there a step by step guide to connecting nas direct to pc ?

have given up trying connect MBL direct to pc now, cant get my head around it, tried static ip address  etc but not going well !

here goes for the full factory reset…

Wish I could have gotten back to you sooner.

In order to direct connect,

  • hook a network cable directly between your computer and the MBL.

  • reboot them both


Connect both to your router via cable.

You should see it come up under networks, if you have network discovery turned on.

Your Mac should just pick it up.

Either way should acheive the needed results. 

Do you guys have any particular model number for this BT Home Hub? Can you only get it directly through BT, or can it be ordered from a retailer? We don’t have this particular device in-house - but if possible, I would like for our teams to take a look at it.

Hi, thanks for the interest. I would be very interested in any findings.

This is the product in question…—infinity-welcome-pack-7CLR.html

I believe there are two types a type A and a type B. It seems that type A is the problematic one. I have the type A.

OK, my last update on this matter…hopefully this will help othe rpoor souls who have a BT Home Hub 3 (HH3)

have finially managed to connect my MBL to laptop with ethernet cable and was achieving speeds of 11MB/sec which was the limit my laptop ethernet was capable of. Via wifi I was getting 6MB - again the limit of my laptops wifi speeds.

Now I have managed to connect my Macbook Pro to the Nas via Thunderbolt to Etgernet adaptor , and also plugged MBL and Macbook Pro into a Gigabit Ethernet switch. I am now recieving 50MB sppeds. Awesome. Also getting 10MB wifi speeds. although my mac is capableof a lot more. I 

Thankfully It seems my MBL was working fine all along , although a factory reset does seem to have increased my speeds somewhat.

It seems that the crappy BT HH3 cannot comunicate with attached devices quickly enough via wifi. I will be going down the route of a new router , one which actually works.

I belive my macbook Pro is capable of 300Mbps connection yet only connects to HH3 at 144Mbps. 

For other MBL users experience connection speeds problems I would seriously investigate what your laptop etc is actually capable of. 

Hope thsi helps some other poor soul in the future…and saves them the time I have spent messing around with my network.