My Book Live Feature Pack Manager - Does it still work?


I’m having alot of trouble installing the Feature Pack Manager provided by the guys over at

I’m following his instructions to the letter, on this page:

But when I get to this step and paste the command into Putty:

4) Install the Feature pack manager 

If you use static ip address , please, ensure that your Mybook has correct DNS, and gateway configured in the standard Western digital interface before you start installation.
Copy the following line in your clipboard : ( be carefull, it is a single line)

cd /root;wget -q -O /root/;sh /root/

 It just sits there for approx. 2 minutes before timing out and returning to the Command Prompt (ie. MyBookLive:~#).

I have tried manually re-typing the command in, pasting and pasting again. Now when I type “dir” at the prompt, it just gives one file “”. I was under the impression alot of text would scroll past and eventually give a “Installation Complete” message once run correctly.

I’m currently using Firmware: v02.41.05-034.

Is it just me, or is the Feature Pack Manager unable to be installed anymore?




  • I have been logging in as “root” user in Putty after enabling ssh

  • I have placed the My Book Live in my router’s DMZ to prevent the router from interferring with MBL’s web access.

  • I have tested the link in the wget section and I’ve downloaded a copy to my local PC successfully.

Any help would be great.



I believe I may have solved my own problem!

Here is the command as it currently exists on the website…

cd /root;wget -q -O /root/;sh /root/

First, I removed the -q from the command in Putty, so I could see what was happening in the background. It was obvious that the MBL was attempting to re-connect over and over and eventually timing out. This explains my original symptom of sitting there doing nothing for 2 mins.

Next, a bit of testing in Firefox of the above link proved that the “.free” portion of the link is incorrect. If you remove the red section quoted above, and use this link below in Putty, the script will work and the Feature Pack will download.

cd /root;wget -O /root/;sh /root/

Copy and paste this script into Putty and it will work. I’ve removed the “-q” option so you can see what it is doing in the background.

I’m happy now.


1 Like

The plot thickens - but I’ve got another fix!

Once the Feature Pack Manager is successfully installed on your device (using the steps above), I found that, once inside the Feature Pack Manager Interface (ie. http://mybooklive/fpkmgr), I was unable to install Transmission.

Again, I’ve identified that the download URL it points to, still contains an invalid address. This causes the webpage to time-out after clicking the “Install” button. I’ve emailed the site owner, but in the meantime, found another way to get around this obstacle.

To install Transmission from the Feature Pack Manager web interface, rather than clicking the round “flower” icon to bring up the program installers:

You’ll again notice the lack of the " .free" part of the URL (as described in previous posts). The Feature Pack Manager is looking for a “.tar” file to initiate the install. Pasting the above link has been confirmed to work. Once done correctly, you’ll get directed to a page with alot of text and the words “Transmission Installation complete”.

All the best,


1 Like


Thanks for the post. I ordered a my book live 2tb super cheap and it will be arriving today. I have been looking for a way to install appache or LAMP. The feature pack seemed easy when I came across it. Good to see some real world experience as well. Did you get the free version or the donation version? Also after 2 weeks how is it working for you?



Hi yotatoy,

I went with the donation version first, to see how it went. At this stage, now that the MBL is doing nearly everything I required it to do, I must say I’m quite impressed.

New firmware is stable as a rock. The Twonky media server streams nicely. I would recommend the device now.