My Book Live External Hard Drive Won't Boot

So I seem to be stuck.

I tried doing a full factory restore via the web interface but it failed & said to manually boot the hard drive. I removed the power plug and then reconnected it to manually boot the hard drive connecting it via ethernet to a Windows PC. The hard drive did not show up in ‘Disk Management’ or ‘My Computer’.

So I downloaded the My Book Live software from the downloads page, and the software detected the hard drive saying “there is a firmware update for the hard drive, to update the firmware click yes”. Clicking yes brought up the web interface where I checked for the firmware update but it said the firmware is up-to-date.

Instead I did a ‘quick format’ from the restore page thinking this would bring the hard drive totally back to its normal state. It said the drive was successfully restored & it will reboot.

After this I have not been able to get the hard drive to start, the My Book Live software doesn’t detect the drive and my computer doesn’t show a hard drive connected via the network.

The hard drive has the blue LED for about 5-10 seconds when I plug it in which disappears and then there is no LED. I don’t need to recover the data but I would like to get the hard drive back to a functional state. Can anybody help me understand how to get this hard drive back up & running?

Appreciate the help.


If the drive stills under warranty I recommend you to contact WD Support for direct assistance.

WD Contact info:

If not, see if the following link helps.

Hi, I have the same problem.

Only difference is, after I reboot, it goes from blue light to white light and it never goes off the white light to green.

It happened when I tried to install new drivers 6 months ago.

I tried resetting the MyBookLive 3Tb drive, unplugged it.

I don’t think its under warranty

Any advice?