My Book Live Duo not detecting direct connection

Hi i just brought a My Book Live Duo 8TB.

I removed the 2x WD 8TB Green and replaced it with 1x 1.5TB RE4 WD Drive. I also upgraded the firmware when i connected  it to my router. My problem is now the MBLD doesnt get detected even if its connected directly to my pc via lan - wireless off. I ran wd discovery and also My Net View.but neither software detects it.

This problem , after updating the nas firmware causes it not to be detected on my network happened with my last NAS ( Non WD) as well.

Is there a way for me to fix this problem ?

I just got the MBLD i dont wanna rma it yet. I also tried resetting the MBLD - through the little hole- but it still doesnt detect network config incorrect.

Maybe somebody could provide me with  a sample static ip config (from the screenshot i provided) for the MBLD when connected directly to my pc via lan ? typing in http://mybookliveduo/ returns an empty page

Thanks In advance


If you replaced the drives, how did you get the firmware on there in the first place?

Hi , the original hard drives were still in there when i updated the firmware.I updated the firmware via the popup that appeared in the webinterface.

I was under the impression that i would still be able to access the mbld web interface even if the hdd wasnt there ? thought there would be a rom or something to manage the NAS Software ?

How do ppl go about to replace the hdd on the mbld ?

Ill plug the  orig hdds back in and report back

Hi i replaced the original drives back in it still doesnt detect? Any suggestions of what i could do ? Or should i rma it?

I wouldn’t be surprised if the RMA is rejected.   You voided the warranty by doing things to the drive that aren’t covered under warranty (like replacing the drives with non-WD-provided drives that don’t match the originals.)

The firmware itself is on the hard drives you removed, so, no, the drive is not going to work with new drives.

Depending on the way you removed / replaced the hard drives, there’s a good chance they’ve been corrupted and will also not function.

The only suggestion I have for you is to try “De-Bricking” the drive and see if you can recover it.

Hi Thx for the reply.

                              I was able to get the mlbd working again after resetting the routers settings. seems like it didnt like the dhcp range:)

ooh only after purchasing the mbld did i realise that the proper way to replace the drive in a mbld is to have WD actually send me a replacement drive with the linux partition data on it.I never thought that wd were so user unfriendly with their My Live Book Duo range. The other NAS servers i have owned so far all have an option to format drives which are inserted.

WD are the first time ive encountered this option removed.

As i hoped I could replace the WD greens in the mbld with my enterprise level WD RE4 1.5TB drive for reliabilty in a NAS.That is what WD markets the RE4 for at least beyond that standard I really dont trust the WD greens with my data running 24/7 - sorry just me ranting hoping wd employes monitor and read my feedback,

I had a read  [GUIDE] Debrick a MyBookLive DUO  ill guess ill  attempt it to try to format my RE4 1.5TB for use with the mbld. ive got one last question if you dont mind answering is it possible to use just 1 hdd in the mbld ?

ill set this question as answered.

Thx for the help