My Book Live Duo not being recognised?

I would really appreciate a little help here! I bought my MBLD about a month ago and took it home, set it up on the network at home and it worked perfectly…however, yesterday we moved house and I cannot get it to work at all on the new network. It shows up in the my computer bit and I can access it by plugging the LAN cable straight into the back of the PC but I bought it so that I could access my stuff anywhere as well as stream programmes on the TV. At the moment I can do neither. Any idea would be warmly accepted, I don’t even mind if I have to wipe the blinking thing I just want it to work!

Frustratedly yours,


Doubt I can help as I am suffering the same with a MBLD that wont stream.  But I would like to know if there is anything different about your network from before?  I have tried mine over two different network hubs as I suspected one was causing a few issues.  It was, but the change did not make any difference to the dlna server.

Not that I can see, everything else is working perfectly but the MBLD is a bit of an ornament at the moment!